Keyboard Layout not respected on F39 clean install

I re-installed F39 yesterday and wanted to use a specific keyboard-layout.
When using the Gnome Settings UI it doesnt matter what layout i choose, it only outputs standard us querty.
I have already seen a similar issue with some recomendations.
I have tried setting the same option with the gnome-settings-cli, localectl and through ibus, but none of that worked.

Before re-installing i was also using F39 with wayland and it always worked just fine.

Update:
I just logged in with Xorg and it still doesn’t work, so this isn’t even related to wayland