Keyboard is not working at all under wayland!

Used to work when I was using the kde spin, but after installing it using fedora everything it no longer works under wayland. Only works on X11.

Welcome to ask.:fedora:edora @techbolt

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Generally other Distributions not use Wayland per default. Are you sure you used Wayland before installing Fedora?

I used wayland first time after installing fedora

  Kernel: 5.18.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: KDE Plasma v: 5.25.4
    Distro: Fedora release 36 (Thirty Six)
  Type: Portable System: Dell product: Inspiron 3537 v: A12
    serial: <superuser required>
  Mobo: Dell model: 01TCR4 v: A00 serial: <superuser required>
    UEFI-[Legacy]: Dell v: A12 date: 05/27/2019
  ID-1: BAT1 charge: 5.4 Wh (100.0%) condition: 5.4/48.8 Wh (11.0%)
    volts: 12.3 min: 11.1 model: LGC DELL 49VTP27J status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse
    charge: 55% (should be ignored) status: discharging
  Info: dual core model: Intel Core i5-4200U bits: 64 type: MT MCP
    arch: Haswell rev: 1 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 890 high: 1164 min/max: 800/2600 cores: 1: 798 2: 799
    3: 1164 4: 799 bogomips: 18358
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen7.5 bus-ID: 00:02.0
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
    520 Mobile]
    vendor: Dell driver: radeon v: kernel arch: GCN 1 bus-ID: 03:00.0
  Device-3: Realtek Integrated Webcam HD type: USB driver: uvcvideo
    bus-ID: 1-1.8:5
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
    loaded: modesetting,radeon unloaded: fbdev,vesa gpu: i915
    resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
    v: 4.6 Mesa 22.1.5 direct render: Yes
  Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0
  Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.18.16-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel port: 4000 bus-ID: 01:00.0
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Dell driver: ath9k v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-1.5:6
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 465.76 GiB used: 13.38 GiB (2.9%)
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB
  ID-1: / size: 464.76 GiB used: 13.19 GiB (2.8%) fs: btrfs dev: /dev/sda2
  ID-2: /boot size: 973.4 MiB used: 191.8 MiB (19.7%) fs: ext4
    dev: /dev/sda1
  ID-3: /home size: 464.76 GiB used: 13.19 GiB (2.8%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: zram size: 7.65 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 55.0 C mobo: 2.0 C gpu: radeon temp: 52.0 C
  Fan Speeds (RPM): cpu: 3200
  Processes: 277 Uptime: 31m Memory: 7.65 GiB used: 2.51 GiB (32.9%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 11
  note: see --pkg Shell: fish v: 3.5.0 inxi: 3.3.19

It does totally block when you log in to your system with Wayland?

Are we talking about the internal keyboard of the dell laptop?

Have you tried with an external one?

I am honestly really bad with patience. After encountering this issue I installed Arch using archinstall with kde. It no longer appears to be broken now. I can only blame fedora for this!

Are you on Wayland now? If you are on arch and using x11 as default, you can’t blame Fedora.

It no longer appears to be broken now.

That means I did try it on Arch

Yes I CAN blame fedora for this mess.

Welcome but I’m gonna have to say calm down first next It may looks fedora did something wrong but based on information you provide us doesn’t give us full story plus you may literally forget a package to install for wayland to interact with keyboard(because you said you used everything install method did you try with fedora kde live iso with wayland you could of save yourself alot of trouble before even go install it) plus you didn’t give answer for external keyboard usage so It may even something else completely. Before finger pointing you should of helping us and provide the information we need so we could of find a solution but attitude you show in messages is also not good as well.

1 Like

Sorry! I will keep that it mind from now on! TBH I think a package for the keyboard to interface with the wayland must be missing because it did work back when I was using the kde spin. It was too bloated and slow so I tried installing kde with fedora everything which did all this problem. Arch must be having the specific package to interface with the keyboard. But Arch was much more lighter than fedora everything so I will keep it! (Here’s the full story if you needed it :grinning:)

Arch is aimed at a different audience. The default Fedora installation is aimed to be used by those who prefer GUIs and heavy desktop environments. (One can also do a minimal install and have it be close to Arch in lightness. One good thing, in my opinion, about Arch is that they don’t mess around too much with the upstream packages, whereas RH and Fedora do a lot of customization.

On the positive side, often, especially with a desktop like Gnome–and RH is pretty much married to Gnome–is that various things, e.g., printers and scanners just work with little or no effort on the part of the user.

I would say now that fedora is a gnome distro. Everything works flawless over there!

Updates, a kwin script which I used broke the keyboard on Wayland.

This. Somehow it didn’t break my keyboard on Arch but it did on Fedora.