Keyboard and touchpad not working

hi ,
i’m using fedora 32 on asus x556
after updating kernel using dnf update from 5.6.6 to 5.8.8 , touchpad & keyboard do not work
i updated to kernel 5.8.9 but still not working
(mouse works well , touchpad & keyboard have the problem)
and no problem in 5.6.6
what’s the problem ?

Yes. I’ve read that some Asus notebooks have this problem with the kernel 5.8
As far as I understand, the whole keyboard is seen as a function key.
But I don’t know what is the working solution.
Try to look here:
In other posts like that, they talk to modify xorg conf file, but if you use Wayland such solution can’t apply. Another suggestion is to create an udev rule.


I’m using xorg but i have to switch to Wayland for login in 5.8.x versions (in xorg screen keyboard doesn’t work for me :frowning_face: may be a new problem )

Solved …
Just update to new version (now 5.8.10)

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.