Kernel (video) issues on MSI Summit E13FlipEvo A12MT

I’m trying out an MSI Summit E13FlipEvo A12MT laptop. I started out with Fedora 36, but have just upgraded to Fedora 37. I’ve used this laptop very little so far, but immediately noticed a couple of big issues. First, if I close the screen or otherwise tell it to suspend, on resume, the display no longer works. The system keeps running but the display stays black and just alternates turning the display backlight on/off. This has been an issue with the FC 36 kernel, the 6.0.0-0.rc4.31.fc38 and 6.1.0-0.rc5.39.fc38 kernels from Rawhide (FC38), and 6.0.8-300.fc37. The only way I’ve gotten suspend/resume to not result in a broken display is by building my own kernel using the one-line patch suggested at

I used the 5.19.8-200.fc36 srpm, added the patch above, and built the rpms.

The other issue I’ve noticed (with all the above kernels, including my custom built one) is the HDMI port on the side of the laptop does not work. Under Win11 (it’s dual boot), the built-in HDMI port will drive a monitor. Running Linux, I get nothing on the monitor connected to the notebook’s HDMI port.

root@fedora ~]# inxi -Fzx
  Kernel: 5.19.8-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-36.fc36 Console: pty pts/0 Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: Micro-Star product: Summit E13FlipEvo A12MT v: REV:1.0
    serial: <filter>
  Mobo: Micro-Star model: MS-13P3 v: REV:1.0 serial: <filter> UEFI: American
    Megatrends LLC. v: E13P3IMS.10A date: 05/20/2022
  ID-1: BAT1 charge: 55.7 Wh (79.2%) condition: 70.3/67.7 Wh (103.9%)
    volts: 16.1 min: 15.4 model: MSI BIF0_9 status: discharging
  Device-1: hid-0003:04F3:2F3D.0001-battery model: ELAN Touchscreen
    charge: N/A status: N/A
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-1280P bits: 64
    type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 1.2 MiB L2: 11.5 MiB
    L3: 24 MiB
  Speed (MHz): avg: 1067 high: 2000 min/max: 400/4800:3600 cores: 1: 500
    2: 2000 3: 488 4: 2000 5: 487 6: 2000 7: 490 8: 2000 9: 400 10: 2000
    11: 488 12: 495 13: 400 14: 400 15: 2000 16: 2000 17: 400 18: 400 19: 400
    20: 2000 bogomips: 79872
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-12.2 bus-ID: 00:02.0
  Device-2: Acer FHD Camera type: USB driver: uvcvideo bus-ID: 3-6:3
  Display: server: X.Org v: 22.1.5 with: Xwayland v: 22.1.5 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915
    resolution: 1920x1200~120Hz
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.2.3
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Micro-Star MSI driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
  Sound API: ALSA v: k5.19.8-200.fc36.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 17.97 GiB (1.9%)
  ID-1: /dev/nvme0n1 vendor: Micron model: 2450 MTFDKBA1T0TFK
    size: 953.87 GiB temp: 41.9 C
  ID-1: / size: 438.14 GiB used: 17.71 GiB (4.0%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-2: /boot size: 973.4 MiB used: 219.8 MiB (22.6%) fs: ext4
    dev: /dev/nvme0n1p6
  ID-3: /boot/efi size: 296 MiB used: 45.9 MiB (15.5%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 438.14 GiB used: 17.71 GiB (4.0%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  Src: /sys System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 411 Uptime: 42m Memory: 15.32 GiB used: 2.76 GiB (18.0%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: N/A
  note: see --rpm Shell: Bash v: 5.2.2 inxi: 3.3.22

welcome to ask :fedora:

Note that I edited your post of the inxi output and added the </> preformatted text tags so the formatting looks as it did on your screen. Please use those tags when you are posting text in the future.

Thank you for adding as much info as you did, and the bug noted above may be the issue for you.

can you test something just make a bootable usb with etcher or fedora usb creator tool and live boot into it and try if in live boot all of those issues you are facing is there test in live mode hdmi to suspend.
and give us the report
if any of the test passed in live mode.

Martin, make a bootable usb of what? FC37 or something else?

FC37 bootable USB image has all the same issues. No HDMI output. Suspend/resume results in a black screen until reboot.

okey it is then comes down to kernel issues which can be solved.
add your inxi output on

It occurred to me just now to check for BIOS updates from MSI (since the ArchLinux page blames this on broken BIOS). There was an update, and I just installed it. Unfortunately, there’s no change in any of the behavior under Linux. I tried the 6.0.8-300.fc37 and my patched 5.19.8-200.fc36 kernels.

1 Like