Kernel versions after 6.6.2-201 make my external monitor and steam games to not work anymore

All kernels after 6.6.2-201, I already tried what you are saying here and it doesn’t work. I think it’s a regression bug that affects only a small percentage of people.

1 Like

Please file a bug report so the developers can look at your specific system for a possible fix.

Note that the great majority of users with the nvidia RTX 3070 Ti GPU have very good luck with the nvidia drivers installed from rpmfusion repo.

1 Like

When I’ll have more time I will try once more to find a fix and if I can’t fix it I will file a bug, btw, do you have any idea where I can file a bug regarding the kernel? Thanks!

I find that filing a bug on bugzilla.redhat.com allows the staff there to triage the item and direct it upstream as appropriate. I don’t know specifically where to file bugs for certain packages.

I wonder if you would be able to try a new clean install and see if the problem continues to exist.
Sometimes continued updates of versions over time may hold some cruft that eventually causes problems that are difficult or impossible to troubleshoot. A new clean install can result in the problem disappearing.

1 Like

That is not an option right now. Eventually I’ll do that, too, if really need it. Thank you!

I have created a bug on bugzilla, we shall see what’s happening, for anyone interested I will post the link here.

Link to bugzilla bug

LE: it doesn’t work.

The log attached to the bug report has:

mar 28 15:42:12 pressure-vessel-wrap[7295]: x86_64-linux-gnu-capsule-capture-libs: warning: Dependencies of libnvidia-pkcs11.so.550.67 not found, ignoring: Missing dependencies: Could not find "libcrypto.so.1.1" in LD_LIBRARY_PATH "", ld.so.cache, DT_RUNPATH or fallback /lib:/usr/lib

Here, on system updated from f39, I have openssl1.1-1:1.1.1q-5.fc39.x86_64 : Compatibility version of the OpenSSL library.

I don’t know what that means, should I install "libcrypto.so.1.1"?

Try installing the package from f39 that provides libcrypto.so.1.1:

$ dnf --releasever=39 install openssl1.1-1:1.1.1q-5.fc39.x86_64

I installed it, no change. :frowning:

Later edit: I tested only with the problem from the steam and it wasn’t fixed at first, but now I’ve deleted the kmod and did an akmods --force for kernel 6.8.8-200.fc39.x86_64 and it seems like the nvidia driver works as expected now, I will need to test the monitor on later time because I don’t have access to it now, but I think it will work if the nvidia driver works now. Will see, I don’t know if it’s related with that package install, but it might be, so thank you!

Hello @formidabilus ,
Sorry to see you’re still having issues. I find it strange that the kernel update would have such a persistent affect. Anyway, I would think at least having the external monitor connected and seeing first what (if anything) any of the NVidia tools available from them, I think there are some at NVIDIA Linux Update|NVIDIA. It looks like you have everything you need installed, and I would recommend uninstalling the kernel debug packages unless you plan on using the debug info they provide since this adds overhead to your running system with the debug info turned on for them. F40 is the first release where Pipewire/Wireplumber video support is active. I think some web browsers are using it too, like FF. This may have an effect on Steam gaming.

Hello, after the latest kernel install - 6.8.8-200.fc39.x86_64 and using akmods --force after deleting the kmod for this kernel, the nvidia driver seems to work as expected for now, at least for steam games. The debug kernels I did delete them before. I will need to test for the monitor, too, on later time. Thanks for the suggestion!

1 Like

Well, the problem is back, after the shutdown, when I started my laptop again, nvidia-smi have No running processes found and it should have at least GNOME-shell and the steam games doesn’t work again, it’s like the driver doesn’t function. I think after I deleted kmod and used akmods --force, after the reboot it still used the previous modules or something and only after I shutdown the laptop it started using the latest module that don’t work. I don’t know… This happened once more before when I wrote that it was fixed and I edited later, but I thought I wasn’t paying attention and it still used the old kernel or something. I tried to delete the kmod again, but no effect this time…

These errors are the culprit I think:

[drm:nv_drm_register_drm_device [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to register device
[drm:nv_drm_load [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to allocate NvKmsKapiDevice

I’ve posted the problem on nvidia forum, too.

❯ sudo dmesg | grep -i nvidia\\\|nvrm
[sudo] password for vnm_rzv: 
[    0.000000] Command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.8.8-200.fc39.x86_64 root=UUID=e281fdfb-17d3-4104-904b-8d787dacd632 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau initcall_blacklist=simpledrm_platform_driver_init rhgb quiet initcall_blacklist=simpledrm_platform_driver_init nvidia-drm.modeset=1 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[    0.043324] Kernel command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.8.8-200.fc39.x86_64 root=UUID=e281fdfb-17d3-4104-904b-8d787dacd632 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau initcall_blacklist=simpledrm_platform_driver_init rhgb quiet initcall_blacklist=simpledrm_platform_driver_init nvidia-drm.modeset=1 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[    7.042330] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input23
[    7.042404] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input24
[    7.042452] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input25
[    7.042504] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input26
[    7.652688] nvidia: loading out-of-tree module taints kernel.
[    7.652692] nvidia: module license 'NVIDIA' taints kernel.
[    7.652694] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    7.652694] nvidia: module license taints kernel.
[    7.775535] nvidia-nvlink: Nvlink Core is being initialized, major device number 510
[    7.776153] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[    7.776258] nvidia 0000:01:00.0: vgaarb: VGA decodes changed: olddecodes=io+mem,decodes=none:owns=none
[    7.823534] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  550.78  Sun Apr 14 06:35:45 UTC 2024
[    7.875522] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.
[    7.943308] nvidia-uvm: Loaded the UVM driver, major device number 508.
[    7.978179] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  550.78  Sun Apr 14 06:23:31 UTC 2024
[    7.982712] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    8.415869] NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x24:0x72:1556)
[    8.415897] NVRM: GPU 0000:01:00.0: rm_init_adapter failed, device minor number 0
[    8.416017] [drm:nv_drm_load [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to allocate NvKmsKapiDevice
[    8.416110] [drm:nv_drm_register_drm_device [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to register device

Are you using secure boot? If so, the signature is certainly a problem.

nvidia: module verification failed: signature and/or required key missing - tainting kernel

Does modinfo nvidia have a signature block? Rebooting before the akmods processing has finished can leave the module unsigned.

There are duplications in the command line:

Command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.8.8-200.fc39.x86_64 root=UUID=e281fdfb-17d3-4104-904b-8d787dacd632 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau initcall_blacklist=simpledrm_platform_driver_init rhgb quiet initcall_blacklist=simpledrm_platform_driver_init nvidia-drm.modeset=1 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau

These shouldn’t hurt, but may be the result of installing drivers from multiple sources without properly cleaning up previous installs.

Yes, modinfo nvidia gives me a signature, a big hex string. I didn’t reboot right after I used akmods and I don’t remember installing drivers from nvidia directly or something.

❯ sudo dmesg | grep secure
[sudo] password for vnm_rzv: 
[    0.000000] secureboot: Secure boot disabled
[    0.006371] secureboot: Secure boot disabled

I got a response from nvidia forum:

Is that a Lenovo laptop? I have the same graphic card and I get the same error. Only kernel < 6.5 will show no issue. You’re not the only one and I wonder which could be the culprit. Obviously something kernel related…

:sweat_smile:

I tried now the latest 6.8.9-200.fc39.x86_64 kernel and it seems to work properly, at least for steam games, I will need to test the HDMI monitor, too. I will need to keep using this kernel to be sure, at first it was ok, after a shutdown nvidia driver stopped working and now after another shutdown it’s back on track. For now this kernel worked for me after 6.6.2-201, all the others didn’t work at all, beside the later two ones that made me think they worked for a moment.

Finger crossed! :crossed_fingers: :joy:

1 Like

6.8.9-200.fc39.x86_64 still only worked at random start-ups, I don’t know why, but in the end I’ve upgraded to fedora 40 and 6.8.9-300.fc40.x86_64 looks fine now.

1 Like