Kernel versions after 6.6.2-201 make my external monitor and steam games to not work anymore

If I type:

❯ sudo dmesg | grep -i secure
[sudo] password for vnm_rzv: 
[    0.000000] secureboot: Secure boot disabled
[    0.005017] secureboot: Secure boot disabled
[    8.065216] Bluetooth: hci0: Secure boot is enabled

but If I remember correctly in BIOS is enabled.

I will try to uninstall Nvidia driver again and see what happens, I’ll let you know.

:thinking: Welp, keep us posted.

I have this problem if I try to remove, I’ve added that exclude:

❯ sudo dnf -y remove "nvidia-*" --exclude=kmod-nvidia-6.6.2-201.fc39.x86_64.x86_64 && dnf -y update --best --refresh
[sudo] password for vnm_rzv: 
Error: 
 Problem: package xorg-x11-drv-nvidia-3:545.29.06-2.fc39.x86_64 from @System requires nvidia-modprobe(x86-64) = 3:545.29.06, but none of the providers can be installed
  - package kmod-nvidia-6.6.2-201.fc39.x86_64-3:545.29.06-3.fc39.x86_64 from @System requires nvidia-kmod-common >= 3:545.29.06, but none of the providers can be installed
  - conflicting requests
  - problem with installed package kmod-nvidia-6.6.2-201.fc39.x86_64-3:545.29.06-3.fc39.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Why did you add the --exclude :thinking: Is there a reason you need to keep that when you are intentionally uninstalling the driver?


When you reinstall the driver in the following command, it rebuild the driver for the kernels you have on the system.

dnf -y remove nvidia-* && dnf -y update --best --refresh

then,

dnf install nvidia-driver nvidia-driver-libs.i686 nvidia-settings akmod-nvidia && dnf -y upgrade --best --allowerasing

Ok, now when I try to install:

❯ sudo dnf install nvidia-driver nvidia-driver-libs.i686 nvidia-settings akmod-nvidia && sudo dnf -y upgrade --best --allowerasing
Last metadata expiration check: 0:01:25 ago on Jo 29 feb 2024 21:14:53 +0200.
No match for argument: nvidia-driver-libs.i686
Error: Unable to find a match: nvidia-driver-libs.i686

I’m curious, What RPM repos do you have installed?

dnf repolist --installed | grep rpmfusion

dnf repolist: error: unrecognized arguments: --installed
❯ dnf repolist | grep rpmfusion
rpmfusion-free                                 RPM Fusion for Fedora 39 - Free
rpmfusion-free-updates                         RPM Fusion for Fedora 39 - Free - Updates
rpmfusion-nonfree                              RPM Fusion for Fedora 39 - Nonfree
rpmfusion-nonfree-nvidia-driver                RPM Fusion for Fedora 39 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                        RPM Fusion for Fedora 39 - Nonfree - Steam
rpmfusion-nonfree-updates                      RPM Fusion for Fedora 39 - Nonfree - Updates

dnf -y remove nvidia-* && dnf -y update --best --refresh

then,

dnf install nvidia-driver nvidia-settings akmod-nvidia && dnf -y upgrade --best --allowerasing

Welp, lets try again without the nvidia-driver-libs.i686 maybe it’ll be brought in through the update later.

This is an error for anything installed from rpmfusion.
It would be
dnf remove \*nvidia\* --exclude nvidia-gpu-firmware
Your command would remove the required firmware package and not all the others that should be removed in that step (such as akmod-nvidia and kmod-nvidia)

This also is an error for installing from rpmfusion. The packages nvidia-driver* are not required nor installed from rpmfusion.
The installation would be best from rpmfusion-nonfree-nvidia-drivers and would be
sudo dnf install akmod-nvidia or instead use sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda if the user wants to have cuda installed.

I’ve installed back nvidia-gpu-firmware as you said before.

removed and installed it back with akmod, back to square one.

Yep, I thought it would be worth the try, The OP is still having issues where the driver is not properly installing after all the methods being used. As I prefaced earlier, I don’t use RPMFusion ( I have always had trouble with it and akmods ) so I mentioned if they were willing, a different approach could work. As I mentioned briefly. . .

I’ve tried it like you said, still no luck.

Please run dnf list installed \*nvidia\* kernel* and post the results.

You also may try running that command as sudo dnf remove \*nvidia\* --exclude nvidia-gpu-firmware --noautoremove

None of the kernel packages should rely on the nvidia packages, but may be called for by something installed from some 3rd party repo other than rpmfusion.

One more thing that might provide a clue.
What is the output of sudo dnf module list?

❯ dnf list installed \*nvidia\* kernel\*
Installed Packages
akmod-nvidia.x86_64                      3:545.29.06-3.fc39 @rpmfusion-nonfree-nvidia-driver
kernel.x86_64                            6.6.2-201.fc39     @@commandline       
kernel.x86_64                            6.7.5-200.fc39     @updates            
kernel.x86_64                            6.7.6-200.fc39     @updates            
kernel-core.x86_64                       6.6.2-201.fc39     @@commandline       
kernel-core.x86_64                       6.7.5-200.fc39     @updates            
kernel-core.x86_64                       6.7.6-200.fc39     @updates            
kernel-debug.x86_64                      6.6.2-201.fc39     @@commandline       
kernel-debug.x86_64                      6.7.5-200.fc39     @updates            
kernel-debug.x86_64                      6.7.6-200.fc39     @updates            
kernel-debug-core.x86_64                 6.6.2-201.fc39     @@commandline       
kernel-debug-core.x86_64                 6.7.5-200.fc39     @updates            
kernel-debug-core.x86_64                 6.7.6-200.fc39     @updates            
kernel-debug-devel.x86_64                6.6.2-201.fc39     @@commandline       
kernel-debug-devel.x86_64                6.7.5-200.fc39     @updates            
kernel-debug-devel.x86_64                6.7.6-200.fc39     @updates            
kernel-debug-devel-matched.x86_64        6.7.6-200.fc39     @updates            
kernel-debug-modules.x86_64              6.6.2-201.fc39     @@commandline       
kernel-debug-modules.x86_64              6.7.5-200.fc39     @updates            
kernel-debug-modules.x86_64              6.7.6-200.fc39     @updates            
kernel-debug-modules-core.x86_64         6.6.2-201.fc39     @@commandline       
kernel-debug-modules-core.x86_64         6.7.5-200.fc39     @updates            
kernel-debug-modules-core.x86_64         6.7.6-200.fc39     @updates            
kernel-debug-modules-extra.x86_64        6.6.2-201.fc39     @@commandline       
kernel-debug-modules-extra.x86_64        6.7.5-200.fc39     @updates            
kernel-debug-modules-extra.x86_64        6.7.6-200.fc39     @updates            
kernel-debug-modules-internal.x86_64     6.6.2-201.fc39     @@commandline       
kernel-debug-modules-internal.x86_64     6.7.5-200.fc39     @updates            
kernel-debug-modules-internal.x86_64     6.7.6-200.fc39     @updates            
kernel-debug-uki-virt.x86_64             6.6.2-201.fc39     @@commandline       
kernel-debug-uki-virt.x86_64             6.7.5-200.fc39     @updates            
kernel-debug-uki-virt.x86_64             6.7.6-200.fc39     @updates            
kernel-devel.x86_64                      6.6.2-201.fc39     @@commandline       
kernel-devel.x86_64                      6.7.5-200.fc39     @updates            
kernel-devel.x86_64                      6.7.6-200.fc39     @updates            
kernel-devel-matched.x86_64              6.7.6-200.fc39     @updates            
kernel-doc.noarch                        6.7.6-200.fc39     @updates            
kernel-headers.x86_64                    6.7.3-200.fc39     @updates            
kernel-modules.x86_64                    6.6.2-201.fc39     @@commandline       
kernel-modules.x86_64                    6.7.5-200.fc39     @updates            
kernel-modules.x86_64                    6.7.6-200.fc39     @updates            
kernel-modules-core.x86_64               6.6.2-201.fc39     @@commandline       
kernel-modules-core.x86_64               6.7.5-200.fc39     @updates            
kernel-modules-core.x86_64               6.7.6-200.fc39     @updates            
kernel-modules-extra.x86_64              6.6.2-201.fc39     @@commandline       
kernel-modules-extra.x86_64              6.7.5-200.fc39     @updates            
kernel-modules-extra.x86_64              6.7.6-200.fc39     @updates            
kernel-modules-internal.x86_64           6.6.2-201.fc39     @@commandline       
kernel-modules-internal.x86_64           6.7.5-200.fc39     @updates            
kernel-modules-internal.x86_64           6.7.6-200.fc39     @updates            
kernel-srpm-macros.noarch                1.0-20.fc39        @fedora             
kernel-tools.x86_64                      6.7.6-200.fc39     @updates            
kernel-tools-libs.x86_64                 6.7.6-200.fc39     @updates            
kernel-uki-virt.x86_64                   6.6.2-201.fc39     @@commandline       
kernel-uki-virt.x86_64                   6.7.5-200.fc39     @updates            
kernel-uki-virt.x86_64                   6.7.6-200.fc39     @updates            
kmod-nvidia-6.6.2-201.fc39.x86_64.x86_64 3:545.29.06-3.fc39 @@commandline       
kmod-nvidia-6.7.6-200.fc39.x86_64.x86_64 3:545.29.06-3.fc39 @@commandline       
nvidia-gpu-firmware.noarch               20240220-1.fc39    @updates            
nvidia-modprobe.x86_64                   3:545.29.06-1.fc39 @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64               3:545.29.06-1.fc39 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                   3:545.29.06-1.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64               3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64          3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64     3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64       3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64          3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64         3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver

For module seems like it is empty:

❯ sudo dnf module list
Last metadata expiration check: 0:44:28 ago on Jo 29 feb 2024 22:37:33 +0200.

I’ll try tomorrow to remove with --noautoremove and update the post.

I am not sure why you have all the kernel-debug packages, but that certainly should not interfere with the nvidia drivers nor the external monitor issues.

I have nothing of the kernel-debug packages nor the kernel-modules-internal packages.

Does the system boot properly with the 6.7.X kernel but simply not activate the external monitor? If it does then please boot that way and provide a new complete inxi -Fzxx output for us.

I left early yesterday, so wanted to chime in recall that OP is not sure if Secureboot is active or not. It’s worth checking at this point.

Sorry for the late response. Kernel-debug packages started to appear after I reinstalled the old kernel after it went wiped out in an update, I think I enabled it in the script to reinstall or something.

I have in the previous comments inxi for a kernel where the external monitor doesn’t work and one inxi for the kernel where it does work.

I tried the remove with --noautoremove flag, too, same result.

This is the inxi for the new 6.7.6-200:

❯ inxi -Fzxx
System:
  Kernel: 6.7.6-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-14.fc39
  Desktop: GNOME v: 45.4 tk: GTK v: 3.24.41 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 39 (Workstation Edition)
Machine:
  Type: Laptop System: LENOVO product: 82RF v: Legion 5 Pro 16IAH7H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 Pro 16IAH7H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    part-nu: LENOVO_MT_82RF_BU_idea_FM_Legion 5 Pro 16IAH7H UEFI: LENOVO
    v: J2CN40WW date: 04/15/2022
Battery:
  ID-1: BAT0 charge: 56.3 Wh (77.0%) condition: 73.1/80.0 Wh (91.3%)
    volts: 16.1 min: 15.4 model: Celxpert L21C4PC1 serial: <filter>
    status: not charging
CPU:
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i9-12900H bits: 64
    type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 1.2 MiB L2: 11.5 MiB
    L3: 24 MiB
  Speed (MHz): avg: 1833 high: 4488 min/max: 400/4900:5000:3800 cores:
    1: 1728 2: 2006 3: 1409 4: 873 5: 4488 6: 1243 7: 2505 8: 570 9: 400
    10: 4488 11: 3061 12: 400 13: 400 14: 3611 15: 3630 16: 852 17: 400
    18: 626 19: 3579 20: 400 bogomips: 116736
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.2 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6
  Device-2: NVIDIA GA104M [Geforce RTX 3070 Ti Laptop GPU] vendor: Lenovo
    driver: nvidia v: 550.54.14 arch: Ampere bus-ID: 0000:01:00.0
    chip-ID: 10de:24e0
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.4
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa alternate: nv dri: iris gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x0a1f res: 2560x1600 dpi: 189
    diag: 406mm (16")
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.3.6 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a6 display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8
  Device-2: NVIDIA GA104 High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228b
  Device-3: Thesycon System & Consulting GmbH D70 driver: snd-usb-audio
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-2.1:4
    chip-ID: 152a:8750
  API: ALSA v: k6.7.6-200.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 0000:32:00.0
    chip-ID: 10ec:8168
  IF: enp50s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-10:8 chip-ID: 8087:0033
  Report: btmgmt ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:467f
Drives:
  Local Storage: total: 1.86 TiB used: 852.8 GiB (44.7%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDKBA1T0TFH size: 953.87 GiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 51.9 C
  ID-2: /dev/nvme1n1 vendor: Micron model: MTFDKBA1T0TFH size: 953.87 GiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 55.9 C
Partition:
  ID-1: / size: 952.28 GiB used: 723.3 GiB (76.0%) fs: btrfs
    dev: /dev/nvme1n1p3
  ID-2: /boot size: 973.4 MiB used: 686.2 MiB (70.5%) fs: ext4
    dev: /dev/nvme1n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 422.8 MiB (70.6%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-4: /home size: 952.28 GiB used: 723.3 GiB (76.0%) fs: btrfs
    dev: /dev/nvme1n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 32 GiB note: est. available: 31.07 GiB used: 4.89 GiB (15.7%)
  Processes: 471 Power: uptime: 0m wakeups: 0 Init: systemd v: 254
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 48 Compilers: gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.33

I don’t know how relevant this is if I log in into one kernel the monitor works, but if I log in into another it doesn’t work, I don’t change the secure boot from one to another, but I think it’s a good idea to check if are dmesg for secure is the same in both, so I will try to check it, thou.

Later edit: it’s the same in both cases:

 sudo dmesg | grep -i secure
[sudo] password for vnm_rzv: 
[    0.000000] secureboot: Secure boot disabled
[    0.004851] secureboot: Secure boot disabled
[    7.443939] Bluetooth: hci0: Secure boot is enabled

2 posts were split to a new topic: Efi partition full

Which kernel is not supporting the external monitor.
You have an nvidia GPU there and many laptops are designed such that the dGPU supports the external monitor and the iGPU supports the built-in screen.

That shows the nvidia driver with current driver version. but if the driver is slightly corrupt it may not work properly.

Please try the following.

  1. sudo dnf remove kmod-nvidia-* to remove the driver that is not working.
  2. sudo akmods --force to rebuild and install the driver for the current kernel.

If you are using the software app to perform upgrades it seems that sometimes the system will reboot before completing the build of the new nvidia drivers and thus can result in a corrupted driver that does not do all that it should. The above steps should solve that issue.

Note that your post with the inxi output was running the 6.7.6 kernel. If still running that kernel and the external monitor is not working then the command in step 1 would be changed to sudo dnf remove kmod-nvidia-6.7.6*, and similarly for each kernel for which the drivers may not be working properly.