Kernel panic when booting Fedora installation media on MacBook Pro 2017

I’m attempting to dual-boot my MacBook Pro 2017 with Fedora. I’m trying to go with Fedora 29 because I have co-workers that have not had good luck with 30 (nobody’s tried 31 yet). I’ve also tried installing 31, but I’m running into the same troubles with both. I’ve been able to figure out all of the configuration items that needed to be changed in order to allow my to boot from my flash drive, and I can successfully start booting from the flash drive, but about 20 seconds after selecting the “Start Fedora-Workstation-Live 29” option, the flash drive activity light stops, and the interface freezes with a few messages on the screen.

One thing to note is that the picture with more lines only displayed when I was trying to install Fedora 29. That message did not show up when I was trying 31. The other picture occurred for both versions.

I’ve tried Google-ing all sort of variations to see if anyone else has had the same issue, but I have yet to find something that helps. Any ideas how I can work through this?

I’m getting something almost the same on a new Lenovo S540

1 Like

I couldn’t find anyone else hitting the same situation, so I’m glad I’m not alone.
2018 macbook pro here, seeing the same issue. One odd thing is that when it crashes, the fans spin up for about 250ms. When it reboots back into OSX it complains of various different types of panics.

I am getting the same error on lenovo s540 15IWL D
I have tried booting fedora 31 and 32(latest)
have you found a solution ?