Kernel Panic after updating to 5.4.7

Right after I ran a “sudo rpm-ostree upgrade” and then “systemctl reboot” I got a kernel panic after the grub menu, which doesn’t ever show up on the first boot for my Silverblue and just chooses the first ostree commit, and before the LUKS2 lock screen. After a cold boot I can see the various ostree commits and choose the one with a working 5.3.16 kernel.

This has happened to me one other time on Silverblue, about a year ago, and I ditched for regular Workstation but I’d like to resolve the issue this time. I really don’t know where to begin to troubleshoot so all suggestions are open. I attached a picture of the kernel panic screen and there is some more information below, but please tell me if I can troubleshoot more to potentially repair my machine.

Laptop: Lenovo ThinkPad E585
Processor: Ryzen 7 2700U
Memory: 16GB
Storage: 256GB NVMe
Firmware: 1.56 R0UET76W

Same here, similar pc ThinkPad E495 Ryzen 5 2500U 16GB Ram 512 SSD Intel Wifi
I have on 5.4.7 and 5.4.8 just updated


Just read on reddit can be for Intel updates, like wifi can broke the kernel.


Please post your experience on the BugZilla report. This seems to be a bug that only affects AMD hardware with Ryzen. I’m trying to get some momentum on this thing so they will fix it.


I had the same issue with similar or identical panic screen as mpphill2.
Disabling Secure Boot in the BIOS Setup Utility allowed the laptop to boot and run without issues.

Laptop Lenovo Ideapad 330S
Ryszen 5 2500U
Memory 8GB
Storage 256GB NVMe
Firmware 7WCN38WW

Workaround: If you want to keep secure boot enabled, boot into the 5.3 kernel and open Terminal. Run “sudo rpm-ostree kargs --editor” and add “trace_clock=local” to the line (I did it right after the word “quiet”). Run your update and boot into the new kernel with no issues.

I’ll be periodically trying new kernels without that argument and also checking the BugZilla, I’ll report back when the issue is fixed.

1 Like

Upgraded to 5.4.14 and I get the same issue.

With Lenovo ThinkPad E595.

Havent found a solution.

Workaround booting in on older kernel version. You can also increase number of kernels that are saved. I have 7 saved atm in the hopes that this issue will be resolved in a later version!

Some user suggested that changing some settings in bios might resolve the problem, specifically setting

UEFI first and CSM on.

I tried this and it resolved my issues and the system boots with the latest Kernel. Annoying bug that might make a novice user like myself anxious!

As of kernel 5.4.17 the original bug has now been resolved.

1 Like