Kernel menu item missing after update to Fedora 34


I updated a system to Fedora 34, and something went wrong. During the update I saw some “No space left on device” messages, and after rebooting the F33 kernel was still running and there were a mix of F33 and F34 packages installed. I deleted some files in /var and ran ‘dnf system-upgrade download’ and ‘dnf system-upgrade reboot’ again.

Now I have what appears to be a mostly F34 system (there are a handful of F33 packages still installed, perhaps ones that have no F34 equivalents).

I have an F34 kernel installed (according to ‘rpm -q kernel’), but it isn’t listed on the boot menu. I tried updating grub with ‘sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg’ but that didn’t fix it.

How do I get the F34 kernel added to the boot menu?

I think kernel-install is normally called to update the boot menu as the final step. You should be able to run that command manually if, somehow, you have the needed packages installed but the boot entry did not get updated. I think it would be something like kernel-install add 5.11.18-300.fc34.x86_64 /lib/modules/5.11.18-300.fc34.x86_64/vmlinuz.


That worked, thanks!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.