Kernel 6.1.6 does not boot

There are similar topics already, but they seem to focus on a different setup. I don’t use encryption and I don’t have an nvidia graphics card. It’s an old hp laptop with a Celeron N3060 and Intel integrated graphics. In my case I wasn’t stuck at a black screen, but the spinning boot thingy was there forever and then it simply rebooted.

I think that a few times in my testing the system actually did boot, I could login; but there was no wifi.

The boot log (journalctl -b-1) for a failed boot ends abruptly after about a 1000 lines with the last message being about flushing the log. Kernel 6.0.18 still boots fine and generates +2500 lines in the log.

Is this an upstream problem? How should I proceed? Is this something to simply wait out and after the next update hopefully all will be fine?

I’ve removed quite and rhgb from the kernel boot options to watch the boot process, this is where it stopped:

I can’t identify any problems.

I’m on kernel 6.1.7 now btw, still the same.

Found a thread with the same problem suggesting to mask wpa_supplicant. That did work for me too, with wpa_supplicant masked I’m able to boot kernel 6.1.7 and login and everything.

After unmasking and starting wpa_supplicant I still don’t have wifi though. What do I need to do to start wifi?

Another suggestion in the thread was to file a bug report. Not sure if that has happened. Where would I file a bug report?

1 Like

Thanks, I had already found that page. However, I don’t think this is a fedora problem, but a upstream driver/module incompatibility. Should I still report this in the redhat bugtracker?

Anyway, I just updated to kernel 6.1.9. The very first time booting the kernel it did boot and I could log in to the system. No wifi though. Subsequent attempts to boot the kernel failed as before.

The wifi in my laptop as reported by lspci is:

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723DE 802.11b/g/n PCIe Adapter

Maybe I should stress that with kernel 6.0.18 everything works fine (including wifi). Thus, no hardware problem.

I have the same problem. Thanks for the clue that it’s the network driver.

My hardware is HP 14 dk0 laptop (3 years old), with the same WiFi controller listed by lspci:
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723DE 802.11b/g/n PCIe Adapter

On Fedora 36 with kernel 6.1.9-100.fc36.x86_64, the system boots as far as wpa_supplicant
and then resets and automatically reboots.

I recently did a fresh install of Fedora 37 on another partition to make sure none of the other settings I’ve played with is causing the problem. When I updated it today (2/4/2023) which brought in kernel 6.1.9-200.fc37.x86_64, it started failing the same way.

I find that by blacklisting the driver, I can get both versions of fedora to boot reliably, and then load the driver and (usually) continue. That is to say, I create a file /etc/modprobe.d/my-blacklist.conf containing this line:
blacklist rtw88_8723de

Once the system is up, I run this command as root:
modprobe rtw88_8723de
and usually I can bring up the network and work. Once it crashed immediately.

This laptop wasn’t used for a few months and missed lots of updates. I first saw the problem on kernel 6.1.7-100.fc36.x86_64. Waiting for the next update didn’t solve the problem for me. Hopefully, eventually…

Thanks for the clues. Now I have a better workaround than running the old kernel.

That information definitely appears to show the driver is causing the problem.
IMHO it should be handled by filing a bug against the kernel and that specific driver version so the issue may be identified and fixed.

Showing it affects all the 6.1 kernels you have tried which fail and that the 6.0 kernel does not fail it will assist the developers to track down the cause.

I would go up to the bar in the top right hand corner and disable and re enable Wi-Fi to get your connection refreshed and up again. At the terminal use lsmod to identify your Wi-Fi driver. Make a note of the name. Don’t mask wpa_supplicant again, but restart, invoke grub and highlight the kernel you want to use - press e and then add modprobe.blacklist=rtw88_8723de, replacing the bit after the equals sign with whatever the name of your Wi-Fi card is. Then press ctrl + x. The system will start with your Wi-Fi card bypassed. Once logged in at terminal invoke: sudo modprobe rtw88_8723de, or whatever the name of your Wi-Fi card is.

With the latest kernel update, 6.1.9, I have found that my Wi-Fi card no longer needs to be bypassed, but I still need to invoke sudo modprobe at the command line to bring back Wi-Fi.

Should I file the bug report in the redhat bugtracker? Or is there a more appropriate place to file the bug report?

Actually, my workaround isn’t as reliable as it first seemed. Today I’ve only gotten it to work once. Most of the time it crashes and automatically reboots as soon as I modprobe the driver. So I’m back to the old kerne.

It seems that waiting a minuter after logging in before loading the module increases the chance of success.

I finally came around to file a bug: 2168658 – kernel module rtw88_8723de prevents system boot.

That is the WiFi module that I have. I can tell you from personal experience that 6.1.9 boots up without hanging but to obtain Wi-Fi access after logging in open a terminal window and enter sudo modprobe rtw88_8723de.

I would suggest you boot in with your most recent issue-free kernel, invoke the command line to remove the problem ones, and run sudo dnf upgrade —refresh to download and install 6.1.9.

Unfortunately I can’t confirm this. For me the kernel 6.1.9 still doesn’t boot without blacklisting rtw88_8723de.

Sorry to hear that you are still experiencing issues. Kernel 6.1.10 was released at the end of last week, so may be worth checking out to see if that makes a difference.

Never be afraid to trust an unknown future to a known God.

Corrie Ten Boom

I have the same issue with the same Realtek RTL8723DE. Fedora hangs while booting 6.1 but works fine on 6.0. I stopped and disabled NetworkManager service and was able to boot in 6.1.11, but if I try to start NetworkManager I get no WiFi. No idea what to do, I’m using 6.0.7 in the meantime.

My experience of the latest kernel update, 6.1.10, is that I find my Wi-Fi card does not need to be bypassed. To avoid the system freezing once I have invoked the modprobe command at the terminal, I wait a minute or two before invoking sudo modprobe rtw88_8723de, and then wait a minute or two before attempting to do anything else at the command line - I only check for updates once the modprobe command has finished processing and the Wi-Fi connection icon has reappeared.

My suggestion would be to log in with your 6.0 kernel, and run sudo dnf upgrade --refresh to check for and opt to install updates. Once those have installed, reboot.

If the system doesn’t get to the account login screen, force a restart and at grub highlight the kernel you want to use - press e and then after rhgb quiet add modprobe.blacklist=rtw88_8723de, then press ctrl + x or F10; ctrl + x for temporary kernel command line change, F10 for permanent. The system will start with your Wi-Fi card bypassed. Once logged in at the terminal invoke sudo modprobe rtw88_8723de as outlined above.

Thank for your advice @maverickofsurrey , it works great. Any idea if this issue (bug) is being addressed already?

Glad to be of help. The issue with the Wi-Fi card has been reported to Bugzilla in respect of previous versions of the kernel.

Unfortunately I can’t report any change with kernel 6.1.10.

The bug report I filed seems to have had no activity whatsoever and I want to express my doubt again, that the redhat bugtracker is the right place for this bug report, since the problem is with the kernel and the module and not fedora / redhat.

Your problem is linked to hardware as old legacy system has not been updated in Fedora kernel compile generic update. Gentoo has moved to 6.11.12, no problem … just wait in BIOS go to option last version, update will follow as Fedora is some where latest and greatest …

Next …