KDE/Plasmashell running in guest in QEMU/KVM interferes with KDE/plasmashell on host

, ,


I am currently experiencing an issues trying to run KDE/plasmashell in a guest OS (Kali) via QEMU/KVM with virt-manager.
As a DE I have installed KDE on the guest, however when I try to log in I only get a black screen. When I run the plasmashell command from within XFCE, the icons in the taskbar of my host, which is also running KDE, start to flicker and move around. I have tried this multiple times, the effect is definitely caused by running plasmashell on the guest.
QEMU is running as “qemu system” if that helps to diagnose the issue.

This confuses me, as I was under the impression that the gust should be isolated enough from the host to not make this possible. I even have the guest connected to an isolated internal network adapter, so it should not even be able to access the hosts localhost, I think at least.

Thank you for any help!

This is happening with the preinstalled Kali qcow2 image. I did a manual install with the iso and the issue does not appear.
I guess this is rather an issue for the Kali devs / community.