Kde plasma settings

I am using kde-plasma on fedora 39. It keeps signing me out after 10 minutes and going back to the login screen. Then, after about one hour, it puts my system to sleep.

I can’t find a way to adjust these parameters. Can anyone tell me how to adjust them?

Thanks.

Did you try changing the power settings?

1 Like

System Settings
Power Management


1 Like

I tried this settings app, and I unchecked “Screen Energy Saving” and “Suspend Session”. Before that, I changed the Screen Energy Savings to 60 minutes, but either way, it logs me out after about 5 minutes.

has a restart been made ?

which kde version do you have ?

please enter in the console:

systemctl status power-profiles-daemon.service

Stefan,

Thank you for your response.

I did try a restart, to no avail.

As to which kde version I have, I am not sure how to find out. I recently upgraded my system to Fedora 39, so it’s the standard version that comes with Fedora 39. And if I didn’t mention it, I’m using Plasma (Wayland).

And here is the output from systemctl status power-profiles-daemon.service:

● power-profiles-daemon.service - Power Profiles daemon

Loaded: loaded (/usr/lib/systemd/system/power-profiles-daemon.service; enabled; preset: enabled)
Drop-In: /usr/lib/systemd/system/service.d
└─10-timeout-abort.conf
Active: active (running) since Wed 2023-12-20 08:12:17 CST; 3h 11min ago
Main PID: 1013 (power-profiles-)
Tasks: 4 (limit: 18922)
Memory: 1.2M
CPU: 232ms
CGroup: /system.slice/power-profiles-daemon.service
└─1013 /usr/libexec/power-profiles-daemon

Dec 20 08:12:17 terraform systemd[1]: Starting power-profiles-daemon.service - Power Profiles daemon…
Dec 20 08:12:17 terraform systemd[1]: Started power-profiles-daemon.service - Power Profiles daemon.

(terraform is my hostname)

in der console
plasmashell --version

According to plasmashell --version: plasmashell 5.27.9

Just to exclude this: did you maybe create multiple activities?

If so, there can be individual power settings per activity (=> “Activity Power Settings”), overwriting the globally adjusted settings (=> “Energy Saving”).
Using such an individually adjusted activity could fake a “not accepting adjustments behaviour” of the plasmashell.

tell me again if you use x11 or weyland?
in the console
loginctl show-session $(loginctl | grep “$USER” | awk ‘{print $1}’) -p Type

try again

Power Management click on default

in the console

sudo dnf clean all && dnf upgrade --refresh --best

sudo reboot

and try to change the settings in suspend session 7 min or so and see if there is any change at all