KDE installation problem

Hello community! First time installing Fedora KDE as it looks great and now facing various issues. Would be great if I could get some help.

Device: HP 2000 Notebook PC
Boot type: UEFI, GPT (currently)

Currently getting this error when opening installer.

Hardware error [errno 5] Input/output error.

I have already tried multiple times to install. I either get complete Black Screen after startup, or this I/O error when installing or get stuck in blank screen after installtion with messege,

UEFI firmware settings

Or sth like that. Clicking firmware settings, I just get diagnostic, bios, boot settings. I could still press escape and somehow go to Minimal grub then.

I tried fedora in MBR legacy to make sure if I blow up my PC. Didn’t work. Tried Win10, worked.

I wanted mainly to use UEFI GPT. AFAIK, my device should support it. But now, I’m good with any installation.

I don’t have a good knowledge, in BIOS. But I think it’s related. Here’s the current BIOS settings.

My guess would be a bad download, a bad copy to flash drive or a failing drive.

Do you have a different flash drive you could try using to install fedora?


I downloaded twice guessing bad download. Flash drive and HDD also should be fine as I installed Win10 at lastly to check, using that flash drive…

That “Legacy Support” line being set to “Enabled” in your screenshot presumably means it will try to boot using BIOS mode, not UEFI mode. Is it set to that because this screenshot was taken when you were trying to set up Fedora to BIOS boot? If not, does disabling that and trying to reinstall work?

Also, if you did want to install with BIOS boot I guess you’d need to move the “USB Diskette” line to the top under the “Legacy Boot Order” section to get the installer to actually run.

1 Like

Turns out you were correct all along. I installed another distros, and after installation, it warned me that my HDD is gradually failing. Not still enough to be flagged by SMART system, but it’s happening…

Yeah. What I thought was, keeping legacy on would be like it would support both legacy and UEFI (cause UEFI didn’t turn ash). But its exclusive…

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.