KDE 6.0.1 on Fedora 40 system sounds can't be muted

I system-upgraded to Fedora 40 which upgraded my laptop to KDE 6.0.1

I have a problem where I can’t turn off the “bong” noise that occurs when the desktop volume is changed by either rolling the mouse wheel when hovering over the volume or sliding the volume.
I’ve set the System Sounds in pavucontrol to 0% volume and muted it but the sounds still occurs.
I also unchecked the “Enable notification sounds” checkbox in “global themes”-> System Sounds but I think that’s unrelated to System Sounds.

So I ran qpwgraph and watched the Graph while causing the System sound ‘bong’ noise to occur. This finally showed me what’s going this. In the pipewire graph I would see libcanberra flash up to do the bong sound and then disappear. I have all the libcanberra services set to disabled:

systemctl list-unit-files -a | grep canberra
canberra-system-bootup.service               disabled        disabled
canberra-system-shutdown-reboot.service      disabled        disabled
canberra-system-shutdown.service             disabled        disabled

But those are just the bootup related ones, I don’t want the bootup sounds either.

My next try was to just use wireplumber to mute the libcanberra, but this seemed to fail:

wpctl status 
PipeWire 'pipewire-0' [1.0.3, mos@msi, cookie:1016130606]
 └─ Clients:
        31. WirePlumber                         [1.0.3, mos@msi, pid:2523]
        32. pipewire                            [1.0.3, mos@msi, pid:2524]
        ..... 
        57. libcanberra                         [1.0.3, mos@msi, pid:3372]
wpctl set-mute 57 toggle

I thought that would mute the libcanberra but it failed with:

Node 57 does not support mute

Maybe I’m doing that wrong

From Ask Fedora to Project Discussion

Added quality-team and removed audio, fedora-kde, kde, pipewire, wireplumber

This seems like more of an upstream KDE issue than a Fedora specific one; you might get more luck at https://discuss.kde.org/ ? But perhaps @ngompa might have an idea?

1 Like

Yeah, this is an upstream KDE issue, please file a bug there.

1 Like

bug 482943

bug was created, I didn’t know what component so it’s general.
Update - dev added a ‘qt’ label

1 Like