It does not work to capture or record the internal audio in Obs Studio or Simplescreenrecorder

It does not work to capture or record the internal audio in Obs Studio or Simplescreenrecorder.

After recently upgrading, when I try to record or capture audio using OBS Studio (in a Wayland session) or using SimpleScreenRecorder (in an Xorg session) the internal audio (or output audio) is not detected, it only captures the microphone input.

I am using Fedora 35. I am not sure what configuration files or what dependencies I should check to solve the problem, I think it is a bug with Fedora since two days ago it was working fine, additionally I have tried in other Linux distributions and they do not have the same bug.

Yes of course, they use older Kernels and still use Pulseaudio.
With F34 the sound server changed to Pipewire with pulsaudio-plugin
F35 came up with Wireplumber as Pipewire session manager.

To debug use:

To catch up please read the change-logs and follow the links to the additional wiki pages:

Could you please give us more infos as :
inxi -Fzx in terminal and post the output as </> Preformatted text here.

1 Like
System:    Kernel: 5.14.17-301.fc35.x86_64 x86_64 bits: 64 compiler: gcc v: 2.37-10.fc35 Desktop: GNOME 41.1 
           Distro: Fedora release 35 (Thirty Five) 
Machine:   Type: Laptop System: Hewlett-Packard product: N/A v: N/A serial: <filter> 
           Mobo: Hewlett-Packard model: 1854 v: 64.0E serial: <filter> UEFI-[Legacy]: Insyde v: F.03 date: 04/19/2012 
Battery:   Device-1: hid-34:88:5d:fb:b8:de-battery model: Keyboard K380 charge: N/A status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-2450M bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 cache: L2: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19954 
           Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 797 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Hewlett-Packard driver: i915 
           v: kernel bus-ID: 00:02.0 
           Device-2: Cheng Uei Precision Industry (Foxlink) HP Webcam-50 type: USB driver: uvcvideo bus-ID: 2-1.3:5 
           Display: wayland server: X.Org compositor: gnome-shell driver: loaded: modesetting unloaded: fbdev,vesa 
           resolution: 1360x768~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 21.2.5 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 
           Sound Server-1: ALSA v: k5.14.17-301.fc35.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.40 running: yes 
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter 
           vendor: Hewlett-Packard AR9485/HB125 802.11bgn 1×1 Wi-Fi driver: ath9k v: kernel port: 4040 bus-ID: 01:00.0 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 
           bus-ID: 08:00.0 
           IF: eno1 state: down mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8 bus-ID: 1-1.2:3 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 465.76 GiB used: 46.49 GiB (10.0%) 
           ID-1: /dev/sda vendor: Toshiba model: MK5076GSX size: 465.76 GiB 
Partition: ID-1: / size: 249.31 GiB used: 46.24 GiB (18.5%) fs: btrfs dev: /dev/sda5 
           ID-2: /boot size: 975.9 MiB used: 261.9 MiB (26.8%) fs: ext4 dev: /dev/sda4 
           ID-3: /home size: 249.31 GiB used: 46.24 GiB (18.5%) fs: btrfs dev: /dev/sda5 
Swap:      ID-1: swap-1 type: partition size: 4.94 GiB used: 0 KiB (0.0%) dev: /dev/sda6 
           ID-2: swap-2 type: zram size: 7.66 GiB used: 241.5 MiB (3.1%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 71.0 C mobo: 0.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 371 Uptime: 2h 58m Memory: 7.66 GiB used: 5.06 GiB (66.2%) Init: systemd runlevel: 5 Compilers: 
           gcc: 11.2.1 Packages: 8 note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.06 

(Thank you for being so kind)

I ran all the commands to debug and they were successful. When I ran systemctl --user status wireplumber, I got an error/failure

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2021-11-18 17:37:20 -05; 3h 53min ago
   Main PID: 1933 (wireplumber)
      Tasks: 4 (limit: 9359)
     Memory: 7.3M
        CPU: 2.312s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─1933 /usr/bin/wireplumber

nov 18 17:37:20 fedora systemd[1664]: Started Multimedia Service Session Manager.
nov 18 19:38:55 fedora wireplumber[1933]: <WpPortalPermissionStorePlugin:0x562d72461ce0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera
nov 18 19:39:01 fedora wireplumber[1933]: <WpPortalPermissionStorePlugin:0x562d72461ce0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

It seems that the problem with Pipewire was already solved and merged into the main branch by your contributors 12 hours ago. Thank you very much for guiding me and telling me about Pipewire and Wireplumber.

1 Like

I think we just need to wait for the update of the package in the Fedora repositories.

1 Like