Issues with updating fedora 32, and downloading fedora 33


I have fedora installed on a machine for a number of years, and updated with no issues.

With fedora 32, when I tried to update I get the following issues:

Unable to download updates:
Cannot download Packages/k/kernel-debug-modules-5.7.15-200.fc32.x86_64.rpm: All mirrors were tried : Last error:
Status code: 404 for (IP: 2001:630:341:12::184)

So when I saw fedora 33 was available, thought I would try that and hopefully side-step the issue. But I now get:

Unable to upgrade to Fedora 33:
package jenkins-2.263.1-1.1.noarch cannot be verified and repo jenkins is GPG enabled: failed to lookup digest in keying for /var/cache/PackageKit/33-metadata/jenkins-33-x86_64packages/jenkins-2.263.1-1.1.noarch.rpm

Any thoughts on what has gone wrong ad needs to be reset would be welcomed :slight_smile:


Is this the exact URL? Because it should be “…/sites/…” instead of “…/…” and “…/Packages/…” instead of “…/-Packages/…”. Also 5.7.15 is outdated and the mirror does not have it anymore. Check here:

Did you try running sudo dnf upgrade --refresh ?

1 Like

You can proceed by temporarily disabling/removing the problematic repos/packages:

sudo dnf config-manager --save --setopt jenkins\*.enabled=0
sudo dnf remove kernel-debug-modules-extras

First, always run a “dnf upgrade --refresh” to verify no problems exist before you attempt a system upgrade to later version. Failure to do that might bite you later.
Second: it is a good idea to disable third party repos before doing the system upgrade. Your error is from a 3rd party repo that appears to not be current in updating for F33 compatibility. Disable that repo and see if the error goes away. It can always be re-enabled after the system upgrade is completed.

The error with upgrading to 32 looks like a mirror issue and likely was or would have been resolved in a day or two.