Issues with shut down and suspend/sleep


Core problem is that the computer won’t shut down or go to suspend/sleep.

I come from the world of Windows computers and have some knowledge about CentOS and RHEL, but overall Linux novice.

I just thought to install Fedora 35 for my desktop use to learn more, but it did not go well.

My computer is HP EliteBook 850 G5 with AMD GPU. Every setting is by default. I only enabled drive encryption when installing.

After I installed Fedora I got this Problem window right away. There are two of these every boot.

Screenshot: Microsoft OneDrive
(IE and Edge might ask to login. Microsoft trying to be too fancy with somekind of SSO when accessing OneDrive. Any else browser should work.)

Then I thought to update packages and kernel to the newest (5.16.something). It did not go well, because the next reboot it did not find disks.

Screenshot: https (snip snap, new user can only put two links to message)!AkB2BxNSQ4E2kvUY_RbqCGvXVIy9tQ?e=dvWtCB

I have read that there are lots of problem with 5.16 so I went and install 5.15.18 which booted to a desktop but had the same original problems.

Journalctl: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Any help is very appreciated.

Hi, from your laptop spec, if my guess right, look like you’re using the optional AMD GPU means now it have hybrid GPU, one from intel (integrated GPU) and one from AMD.

From your ABRT screenshot there a message fbcon: Taking over console and I believe it related to your journalctl messages error related to amdgpu.

Would you like to install sudo dnf install hwinfo then run hwinfo --gfxcard and post the result here?


Also worth making sure your system is up to date. That’s usually the first thing we do on a fresh install.

It is hard to find specs about this spesific model. ID is 2FH28AV. This is closest what do I find: HP Elitebook 850 G5 | Intel Core i7-8550U | 16GB RAM | 256 GB SSD | 2F – ViaElectron

Here is output of hwinfo --gfxcard:

16: PCI 100.0: 0380 Display controller
[Created at pci.386]
Unique ID: VCu0.7Crp7G10q66
Parent ID: z8Q3.JrRFBiTHYK7
SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “ATI Lexa PRO [Radeon RX 550/550X]”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x699f “Lexa PRO [Radeon RX 550/550X]”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x83b4
Revision: 0xc3
Driver: “amdgpu”
Memory Range: 0x90000000-0x9fffffff (ro,non-prefetchable)
Memory Range: 0xa0000000-0xa01fffff (ro,non-prefetchable)
I/O Ports: 0x3000-0x30ff (rw)
Memory Range: 0xba300000-0xba33ffff (rw,non-prefetchable)
Memory Range: 0xba340000-0xba35ffff (ro,non-prefetchable,disabled)
IRQ: 16 (2 events)
Module Alias: “pci:v00001002d0000699Fsv0000103Csd000083B4bc03sc80i00”
Driver Info #0:
Driver Status: amdgpu is active
Driver Activation Cmd: “modprobe amdgpu”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

29: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.386]
Unique ID: _Znp.bF+hvnX9fE6
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Device Name: “Onboard IGD”
Model: “Intel UHD Graphics 620”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x5917 “UHD Graphics 620”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x83b2
Revision: 0x07
Driver: “i915”
Driver Modules: “i915”
Memory Range: 0x1ff2000000-0x1ff2ffffff (rw,non-prefetchable)
Memory Range: 0x1fc0000000-0x1fcfffffff (ro,non-prefetchable)
I/O Ports: 0x4000-0x403f (rw)
Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
IRQ: 142 (9363 events)
Module Alias: “pci:v00008086d00005917sv0000103Csd000083B2bc03sc00i00”
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: “modprobe i915”
Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #29

Yes. That was and is first thing what I do with fresh install :slight_smile:

1 Like

Hi again, for your graphic card I assumed it should be okay despite the annoying ABRT error messages. Would you like to check the BIOS and find if there any setting to activate your AMD GPU? May be you could start from there.

I just read again about your second images (failed to boot after update), look like there a missing partition. Would you like to compare the UUID inside your cat /etc/fstab with the result of lsblk -apf and find what the device that have UUID that presented on the second image here?

I really would like to check BIOS, but I can’t because it is protected by password and is managed by 3rd party.

I had CentOS 8 installed earlier and it worked well with installed AMD driver.

And about second imange. I have already re-installed Fedora. I check that one later. It is anyway addittional problem which only occur with 5.16 kernel.

I tried 5.16 again and here are the results.

fstab and lsblk: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.
Screenshot when booted:!AkB2BxNSQ4E2kvUbySv4WP5F_Sy8SA?e=MKyjnQ

I’m not quite sure, but since it root partition, look like you’re right that this is kernel issue. My guess related to your nvme drive vendor like the other forum here. May be you want to report it to

1 Like

If you’re willing to reinstall again, i would recommend not use the DEFAULT INSTALL in everything and don’t set up your disk with BTRFS, which is the default filesystem for Fedora nowadays.

The weirdest part for me is that in CentOS these problems don’t appear.

I am willing to do reinstallation many times as needed. Already have done it like ten times.

Yes, BTRFS is default. Why you do not recommend it and what do you recommend to choose?

And yes, CentOS 8 worked really well. Used it over a year every day. Even graphic softwares worked (rendering, etc…).

I tried with 5.16.8 kernel and disk problem exist with that too.

I got access to BIOS and disabled AMD GPU. After that even 5.16 kernels works well.

1 Like