Issues with Lenovo Miix 300-10IBY

Hi everyone!

I post here, because i didn’t see a better topic so far, but I am new both here and to the Linux world in general, so I may have missed something, just to be clear. The post is quite long and has many topics, maybe I should break it down into several smaller ones?

I got cheap a Lenovo Miix 300-10IBY. Born with Win 8.1, it had Win 10 32bit on it, and one could not do that much with it.

I decided to grab the chance and learn.

32bit EFI
After some trouble with the 32 bit EFI (despite the x64 processor) I managed to have Ubuntu running, because I saw someone talking about that and it was a logical place to start, hoping into a more flexible hardware support. I tried also vanilla Debian, Mint (no way to have the PulseAudio working), PopOS (no way to install it, just live) and Zorin (no way to fix the wrong screen orientation). I did not want to stay necessarily in that family, so I tried Arch. I found a version with the 32bit EFI trick already onboard, I could boot up, but there the wifi was a pain, and I am not yet good enough. So after more tries with Void (that I actually liked the most, and worked ok, but without sensor-driven screen rotation, only forcing it manually into a certain orientation) I landed here.

Fedora
Everything works out of the box with Fedora 31, it boots withouth hacks and installs flowlessly, apart from cameras and screen orientation. But…

The screen orientation I fixed creating an alias inside /etc/udev/hwdb.d/61-sensor-local.hwdb as inside Kevin Becker’s website here, the matrix structure that works for the Lenovo Miix 300 is 0, -1, 0;-1, 0, 0;0, 0, 1 (thus inverting both axis and turning everything by 90 degrees counterclockwise). Great so far, the touch works too and follows the screen orientation (never got here before!).

Booting
I have an issue booting, the tablet goes into “no bootable device” error every time I turn it on, but then clicking on “ok” and selecting the booting device again, ti works. There are 2 recognised “Fedora” entries, no idea if it is something with what is inside the current EFI partition created by Fedora. No other distro ever did that, I tried installing Fedora again partitioning by hand following some guides, but the result is exactly the same.

Cameras
Now the cameras… there is a front camera and a back one, none of them are alive in any of the distros I tried so far. I did not find the producer, model, hardware id, nothing.

  • How could I ever identify the hardware, first of all
  • Are there known ways, fixes, work-arounds? The cameras always have been a problem, since I know Linux (I am a total noob, but have been into computers since the mid 80s…).

Cheers and thank you for what ever hints you may give!

Dario

Ah BTW here is the pci & usb list

00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0f)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0f)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0f)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0f)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0f)

and

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 258a:1015 USB2.0 Hub
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
here with tree:/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 480M
|__ Port 2: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
|__ Port 2: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
|__ Port 2: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M

Hello @alu77, I moved your post to a brand new topic. And yes, sometimes it is better to write a topic for each different issue rather that write a single one with many different problems.

1 Like

Grazie @alciregi! :blush: Let’s see if anyone is ever coming up with some tips!

1 Like

Hi Dario & Alessio,
after 2 days of trying to install Linux (tried a variety of distributions) on my Lenovo Miix 300-10IBY tablet, I finally arrived in exactly the same situation. After all, I’m quite happy that it now works with Fedora 40 (Workstation). Only the cam problem and this strange booting issue still remain. It would be great, if these two issues could also be resolved. Anyway, have a nice day.