Issues with graphic shaders AMD Fedora 32

Background: I have been using Fedora consistently since F30 and I am enjoying my experience so far. Any issue I’ve come across I’ve either been able to solve myself or find documentation on how to solve it, except for this problem. In my research so far I’ve gathered that there are many different issues with Fedora and AMD which I was not aware of when I bought my new laptop. I am using AMD Ryzen 3 with Radeon Vega graphics. So far everything I’ve tried has not solved the problem.

The Problem: The problem I am having is with the shaders not rendering properly in certain games. For example, I have no issues running Minecraft, but the problem shows up running CS GO on Steam and Albion Online. These games are still playable but it’s annoying to have to look at the graphics sometimes. There have even been a couple times in which a graphic in these games will render correctly but then the next time not render correctly. Both Steam and Albion Online were installed via Flatpak. Here is a screenshot so that you can see what I am seeing. I have more if needed.

Outputs: Here is my output for “kmod list | grep amd”
edac_mce_amd 32768 0
kvm_amd 110592 0
kvm 815104 1 kvm_amd
amdgpu 5742592 12
amd_iommu_v2 20480 1 amdgpu
gpu_sched 40960 1 amdgpu
i2c_algo_bit 16384 1 amdgpu
ttm 122880 1 amdgpu
drm_kms_helper 249856 1 amdgpu
drm 618496 16 gpu_sched,drm_kms_helper,amdgpu,ttm
ccp 106496 1 kvm_amd
pinctrl_amd 32768 1

Please let me know if you need any further information.
Thank you.