Issues with F39 Workstation install

I wanted to setup my os partitions like ive had for many years using fedora with the new F39 install.
But the installer overrides my size values and partition size settings!

Actual install result:

This is all in reference to fedora install on dev sda below:

$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
sda      8:0    0 698.6G  0 disk 
├─sda1   8:1    0     2M  0 part 
├─sda2   8:2    0     1G  0 part /boot
└─sda3   8:3    0 697.6G  0 part /var
                                 /home
                                 /
sdb      8:16   0 465.8G  0 disk 
├─sdb1   8:17   0     2M  0 part 
├─sdb2   8:18   0     1G  0 part 
└─sdb3   8:19   0   464G  0 part 
sr0     11:0    1  1024M  0 rom  
zram0  252:0    0     8G  0 disk [SWAP]

*) I had specified in the installer for the /boot /var and /home to be separate partitions.
However they are not. They are sub-volumes? as per doc page on https://docs.fedoraproject.org/en-US/workstation-docs/disk-config/
I definitely needed the /home partition to be distinct from the “/” root partition.
I am not sure how this setup of home would help in re-installing the /root partition but keeping /home intact?

  • But no matter what I put in for bootefi partition, installer will switch space back to 2 MB!!!
    Its the one listed as sda1.
    I could hve sworn my first attempt of the install gave me an error stating that 512MB was the minimum for the bootefi partition. Didnt see that error again though.

Less serious issues:

*) Installer doesnt prompt me to enter users, root passwd or hostname like it used to.
I get that users/passwd has been moved to first login setup screen.
Setting of root passwd is gone! I’d like to set it. Its my system.
(Apparantly, i have to go through grub for this? - horrible choice).
Setting of the hostname is also burried.

I liked the previous install setup of asking for users/root passwd and hostname during the install process.

  • gcc is no longer installed as part of distro. Has to installed separately.
    Emacs not installed by default (now this is true crime!),

You might find the “Everything” installer to be a bit less restrictive in how and what it will let you install.

https://alt.fedoraproject.org/

If that still doesn’t let you do what you want, you might have to resort to using dnf’s --installroot option to bootstrap a system.

It would appear you installed in legacy (MBR) mode and that partition is the BIOS BOOT partition which has a fixed size. You do not have a partition /boot/efi

Had you installed in efi mode then the default size for /boot/efi is normally 600M.

Yes, you got separate subvolumes instead of partitions since you used btrfs file system. It is possible to do a reinstall on btrfs while retaining the data in /home.

Note that when using btrfs all subvolumes share the same main volume so the space is shared and allocated for use as needed to each subvolume. This means that having a separate /var is meaningless. It could just remain part of the root subvolume and avoid the hassle of managing the separate subvolume for /var.

Simply use the command sudo passwd root so assign a password to the root user.

Since fedora relies on systemd the user must use hostnamectl to display or set a hostname.
man hostnamectl or hostnamectl --help to see how.

1 Like

Thanks for the response.

I didnt chose that legacy option. I just downloaded the F39 installer and chose “install” fedora to local drive. Unless I clicked on a wrong button on one of the first screens.
The 2 MB partition is what the installer was showing as the bootefi partition, even though now it doesnt show it. Im going to attach pic of screen as soon as it uploads.

Note that the BIOS Boot partition is what I was trying to set to 512 MB and then tried 1 GB.
Each time the installer substituted 2 MB for the size.
(this was before setting the /home partition, so there definitely was plenty of space for even a 1 GB partition).

“BIOSBOOT” is a bit of a misnomer. In actually, that is a special partition that only the GRUB boot loader needs (and can access or use). It should really be called the “GRUBBOOT” partition. It can only be 1 to 2 MB in size and it is formatted with a special file system specifically for GRUB.

2 Likes

When booting from the install iso you should be able to select the choice of uefi or not.
When the bios is set to boot uefi only then the usb will boot only in uefi mode.
When the bios is set to CSM mode then the bios boot menu must be used to select the boot mode for the device. The default is usually legacy (MBR) mode unless the user uses the bios boot menu and selects UEFI mode from the usb device.

If you want to use uefi boot mode the simplest to avoid the necessity to select each time a new device is booted would be to enter the bios setup and set the boot mode to uefi only. Alternatively remember to select the bios boot menu (often using the F8 key when powering on) and select uefi for booting from the usb device.

Also note that when using MBR boot the system does not support secure boot

Your image clearly shows that it is creating a BIOS Boot partition.

Not true exactly. BTRFS was defined to use the entire space not already allocated to sda1 & sda2.
If you want to use uefi then you must boot the installer in uefi mode

1 Like

Got it. No wonder installer kept reducing this partition size down to 2 MB.
Although, there should be a message for the override of user input.

The btrfs filesytstem uses subvolumes which can be individually handled by the various tools, much like separate partitions in a LVM arrangement. So /home is distinct from / and /var.

1 Like

You have to chose “Standard Partition” instead of “btrfs” or “LVM” on the previous screen.

1 Like

Boot mode is selected when the BIOS is in control. The OS has no way to control nor change that so messages would be immaterial and it would be impossible to change anything by the time the user could possibly see the message.

1 Like