Issue with IoT and static IP address

Using the latest Fedora IoT installer (Fedora-IoT-IoT-ostree-x86_64-32-20200429.0.iso) after setting up a new system it’s not possible to set a static address and have it persist across reboots. In the installer if I configure a static address and reactivate the interface it correctly sets the address but after the system reboots it’s back to utilizing a DHCP address. If I then modify the connection to use a static address on reboot it’ll create another connection named “Wired Connection” and that connection will use DHCP again.

Thinking this was caused by the zezere-ignition pieces I disabled those but it didn’t seem to help. Does anyone have any ideas of how to correct this?