Issue with Intel 7265 Wifi Card after latest update

Hello, my Intel 7265 Wifi Card / Wifi Adapter no longer works after my latest update. The device works fine on windows, only fedora is giving me issues.

inxi gives me

Device-2: Intel Wireless 7265 driver: iwlwifi
  IF: wlp3s0 state: down mac: <filter>

nmcli gives me

        "Intel 7265"
        wifi (iwlwifi), 54:14:F3:12:D2:8E, plugin missing, hw, mtu 1500

What should my next steps be?

Hello, same thing on Fedora Silverblue with a MEDIATEK Corp. MT7921K (RZ608)

Look for your wifi card

lspci -knn | grep -A 3 Network

nmcli device status

And file a bug report in redhat bugzilla

Immediate Soln will be Boot with older kernel from grub and check if that works well in prior kernel.
If does or does not.
You can debug that

First look for Driver Check if the correct driver for your Intel 7265 Wi-Fi card is still there on your system
lsmod | grep iwlwifi

If the iwlwifi module is not listed try to run
sudo modprobe iwlwifi
Reboot your system or restart the network manager
sudo systemctl restart NetworkManager
Ensure that the Wi-Fi interface (wlp3s0) is not in an “unmanaged” state

If so set to managed sudo nmcli device set wlp3s0 managed yes
If you need more help provide the output of
lsmod | grep iwlwifi with your question.

Also if booting into the older kernel resolves the issue put a bug report in bugzila redhat so that can be solved in upcoming kernel releases

Hello, thanks for the reply! This is what I am getting as an output even after trying multiple kernel versions.

lspci -knn | grep -A 3 Network

03:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59)
	Subsystem: Intel Corporation Dual Band Wireless-AC 7265 [Stone Peak 2 AC] [8086:5010]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

nmcli device status

DEVICE           TYPE      STATE                   CONNECTION         
enp0s20f0u1u1u3  ethernet  connected               Wired connection 2 
lo               loopback  connected (externally)  lo                 
enp2s0           ethernet  unavailable             --                 
wlp3s0           wifi      unavailable             --          

lsmod | grep iwlwifi

iwlwifi               462848  1 iwlmvm
cfg80211             1282048  3 iwlmvm,iwlwifi,mac80211

sudo systemctl restart NetworkManager
Verify that you have driver
sudo dnf install iwl7265-firmware
sudo modprobe -r iwlwifi && sudo modprobe iwlwifi
It will reload that driver.

sudo dnf install iwl7265-firmware
Last metadata expiration check: 0:00:43 ago on Fri 07 Jul 2023 02:12:40 PM CDT.
No match for argument: iwl7265-firmware
Error: Unable to find a match: iwl7265-firmware
sudo modprobe -r iwlwifi && sudo modprobe iwlwifi
modprobe: FATAL: Module iwlwifi is in use.

Maybe the firmware name is not right can you look for the right one. Dnf search

cant seem to find anything, edit I did find them but I already have the firmware installed

I will look into it when i have access to my lapi in the mean time you can look for other websites help forums or if someone else helps you out.

Ive tried to look around to find a solution, but as of now I am still unable to find a solution.

Alright, I think I may be onto something here…

When I try to install NetworkManager-wifi it looks like there is two of them installed, Is this normal? If this is not normal, would it be possible this could be causing my issues?

sudo dnf install NetworkManager-wifi
Last metadata expiration check: 0:21:56 ago on Fri 07 Jul 2023 11:47:45 PM CDT.
Package NetworkManager-wifi-1:1.42.6-1.fc38.x86_64 is already installed.
Package NetworkManager-wifi-1:1.42.8-1.fc38.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

Im not quite sure what to make of this

NetworkManager-wifi.x86_64                                                               1:1.42.6-1.fc38                                                  @updates                                         
NetworkManager-wifi.x86_64                                                               1:1.42.8-1.fc38                                                  @updates                                         
NetworkManager-wwan.x86_64                                                               1:1.42.6-1.fc38                                                  @updates                                         
NetworkManager-wwan.x86_64                                                               1:1.42.8-1.fc38                                                  @updates 

When looking on the output of journalctl, I see that it somehow cant find the wifi plugin and I’m starting to wonder if it has to do with having these two versions of the wifi plugin installed or if there is something else going on.

Jul 08 00:28:58 desktop-main NetworkManager[1150]: <info>  [1688794138.2447] manager: (wlp3s0): 'wifi' plugin not available; creating generic device
Jul 08 00:28:58 desktop-main NetworkManager[1150]: <info>  [1688794138.2453] manager: (wlp3s0): new Generic device (/org/freedesktop/NetworkManager/Devices/3)

Turns out my intuition was correct! If anyone encounters these types of errors in the future, this is exactly how you can fix it.

Step 1. Remove NetworkManager-wifi using

sudo dnf remove NetworkManager-wifi

Step 2. Check through the output of this command to see if any instances of NetworkManager-wifi remain, if so try and find a way to remove it.

sudo dnf list | grep NetworkManager

Step 3. Re-Install NetworkManager-wifi using

sudo dnf install NetworkManager-wifi

Step 4. Check that NetworkManager-wifi is installed using this command and looking for a SINGLE installation of NetworkManager-wifi.

sudo dnf list | grep NetworkManager

Step 5. Restart the NetworkManager service using

sudo service NetworkManager restart

Step 6. Check to see if the device is up and running using


If all goes well, you should see wifi re-appear in settings! If you do not see it there, restarting your device never hurt anything.

If anyone has anything they would like me to add to this step by step solution, please let me know!