Issue installing Maltego (Fedora 38)

Hello, I ran into a issue installing Maltego on Fedora 38.Followed these instructions and downloaded from the official site but I ran into this.

$ maltego egrep: warning: egrep is obsolescent; using grep -E egrep: warning: egrep is obsolescent; using grep -E egrep: warning: egrep is obsolescent; using grep -E egrep: warning: egrep is obsolescent; using grep -E egrep: warning: egrep is obsolescent; using grep -E WARNING: package not in java.desktop java.lang.UnsatisfiedLinkError: Can't load library: /usr/lib/jvm/java-17-openjdk- at java.base/java.lang.ClassLoader.loadLibrary( at java.base/java.lang.Runtime.load0( at java.base/java.lang.System.load( at java.base/jdk.internal.loader.NativeLibraries.load(Native Method) at java.base/jdk.internal.loader.NativeLibraries$ at java.base/jdk.internal.loader.NativeLibraries.loadLibrary( at java.base/jdk.internal.loader.NativeLibraries.loadLibrary( at java.base/jdk.internal.loader.NativeLibraries.findFromPaths( at java.base/jdk.internal.loader.NativeLibraries.loadLibrary( at java.base/java.lang.ClassLoader.loadLibrary( at java.base/java.lang.Runtime.loadLibrary0( at java.base/java.lang.System.loadLibrary( at java.desktop/sun.awt.X11GraphicsEnvironment$ at java.base/ at java.desktop/sun.awt.X11GraphicsEnvironment.initStatic( at java.desktop/sun.awt.X11GraphicsEnvironment.<clinit>( at java.desktop/sun.awt.PlatformGraphicsInfo.createGE( at java.desktop/java.awt.GraphicsEnvironment$LocalGE.createGE( at java.desktop/java.awt.GraphicsEnvironment$LocalGE.<clinit>( at java.desktop/java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment( at org.netbeans.core.startup.Main.start( at at java.base/

1 Like

Hi @gigaxavo , welcome to the community.

You’re probably missing a package that provides this shared library. Try this and install the package you think you need:

sudo dnf repoquery --whatprovides '*/'

Or simply do this to install a missing file if you know the path

sudo dnf install /usr/lib/jvm/java-17-openjdk-
1 Like

You also could tell dnf to install that file with sudo dnf install */ and if it gives multiple package names then install only the one you think is appropriate.

1 Like

Tried what @computersavvy said but still there is no change.I got the same response as before.

I got this error whenI tried your way.

AMDGPU 5.5.3 repository                                                                                                                                                                                       438  B/s | 533  B     00:01    
Errors during downloading metadata for repository 'amdgpu':
  - Status code: 404 for (IP:
Error: Failed to download metadata for repo 'amdgpu': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Since this issue seems not related to the amdgpu in any way you might try adding
--disablerepo=amdgpu into the dnf command line so that error no longer appears.

1 Like

Tried disabling the repo but nothing happened.

Solved the issue by opening the Software GUI and disabeling the repo, that seemed to only work for some odd reason.Then I just looked up what I was missing using sudo dnf repoquery --whatprovides '*/' and Maltego works fine now.Thank you all for your advice and time.