Is there other options for Fedora OS entering ISP-router instead of Windows OS setup software. Can I use the CLI (Terminal) to configure DHCP and WAN connectivity

After doing a Hardreset on my router (The ISP modem) I am still locked out of option by loggin in to the ISP GUI.

Is this because the software for the router interface is for Windows or Macintosch and unfortunately not Fedora Linux ?


I’m wondering if there is a way around PPPOE to configure the ISP-router settings perhaps by using CLI in Terminal.

Or if I can secure and set up my home network in the Fedora preferences in the wired and Wifi connection settings.

The Fedora settings for WAN and Wifi
I have problem entering the Router setup Wizard software through the ISP-modem using the CLI ( Terminal ).

I was able to get the IP by typing the command in CLI IP addr show. But typing it into the browser ( Firefox ) gives no respond.

How to Check IP Address on Fedora Desktop

I would like to learn to set up my SSID and Username and other network settings manually by the CLI.
Does anyone have this experience. Changing your networks settings by the Terminal by using shell script ?

From what you say it appears your PC has connection to the router.

Most modern routers have a web page management that can be accessed from the lan. Have you tried opening the browser and going to and see if a page opens up to manage it? Usually the ISP tool is for windows use only and does not use the command line but actually is a substitute for browser access to the web interface. is the common default IP for most routers but may not be correct for yours. Usually the router user manual gives the default IP address for the lan side as well as the default user name and password to log in for administrator access.


Check the backside of your router, there is a sticker with more info’s. If you don’t find the info needed use the model nr. to search in internet about “Default login Router (model-nr)” or similar.

1 Like

Yes I first tried Hardreset of router out and even wrote the vendors customsupport. But as it is Sunday ( In my country a day companies emploies are off work) and I’m unpatienced. I try to fix this the Linux way but maybe it is a browserissue when I type in the IP address and receive a time out because no responding.

I also tried to do the log in on the web page management and used the accountinformations I received from the vendor by mail to change the default settings.

Could the problem be entering the Set up Router wizard by a Fedora Linux OS and not by Windows or Macintosch OS ?

I know but I can not get acces to the routers set up wizard where I can use that data to change it. So I thougt the provider limit it by a one time username and password they send me the first time. there is a problem entering the routers configuration software. But it seems that it is not something I can fix through the Terminal with Shellscript commands.

Could the problem be entering the Set up Router wizard by a Fedora Linux OS and not by Windows or Macintosch OS ?

I don’t think so, they maybe just changed the default to their own settings. I guess looking with them is the best option.

1 Like

Make sure your using a wired connection to the router.Also in Gnome settings make sure the network is set to Automatic(DHCP).


It is critical when first doing the setup on a wifi router that your initial connection be via ethernet (on the LAN side). The wifi will not yet be configured so cannot be used for the first connection.


I believe Dlink uses192.168.0.1. As mentioned elsewhere, a direct ethernet connection is probably the easiest choice when starting from a hard reset. From there, you should be able to log in to the admin web using the instructions from the vendor and any browser – there is no dependency on Mac or Windows.


ip addr show will give you the IP address of your Fedora computer, but you want to connect to the router, right? For the DLINK router, browse to You should get prompted for the administration userid (admin) and password (blank), then get to a configuration page. If I recall correctly, there’s a “wizard” option that guides you through setup, or you can do it manually. Oh, here’s a link:
[Step 1: Open your web browser and enter http://dlinkrouter or http://dlinkrouter.local or into the address bar. The default username is Admin and the password is blank (nothing) .


How do I change the Wi-Fi password on my router? | D-Link UK

](How do I change the Wi-Fi password on my router? | D-Link UK)](How do I change the Wi-Fi password on my router? | D-Link UK)

1 Like

Yes, exactly.
Most, if not all, routers are only accessible by LAN cable. Your client needs to have DHCP enabled in order to get its connection.

Then find your web interface of your router.
ip a s
Will show your network details.
The router ip is most likely the same ip just ending with a “1”.

E.g. if your address is, the router will have

1 Like

Hey Dave! Thank you for your for taking your time and answere.

The shell is a command-line interface to the Unix operating system. It’s similar to the DOS prompt in a Microsoft Windows environment, albeit much more powerful.Linux Network Administrators Guide

I do understand that I can manage it through the GUI example your describe. The subject of this matter is to go more deep behind and manage my router settings throug CLI by the Terminal Networking Interfaces. I read IP Accounting that the Linux Kernel is kind of firewire which can be configurated manually Setting Up Linux for Firewalling by the Linux administration guide Linux Network Administrators Guide.
As the screenshot shows a Windows Network is running with out it’s existence. I had somebody very skilled to set it up for me. Who can write programs in Fedora Linux. I can’t remember what was done and how to change it. I wish to learn and understand it by shell scripting. I need to have an overview as I running on different devices at different OS. But need to set it up at the Fedora Os device.

Thank you for your help-

How do I make sure that DHCP is enabled correct ? Is there a way through CLI.

I checkt on the d-link emulator, and could not see any infos about ssh. Normally when you want access via terminal you need acces over ssh. If A router has it, it normally shows up in the settings to activate or deactivate. Because of security issues.

1 Like

Just a guess before going to bed. I havent done my homework by reading all. But a superficial guess to go and have a sneak peak.

The SSH protocol has the ability to securely forward X Window System graphical applications over your encrypted SSH connection, so that you can run an application on the SSH server machine and have it put its windows up on your local machine without sending any X network traffic in the clear.

Is PuTTy usefull here and the SSH be entered or should I go for the routers software ?

By the way. I just use the D-Link as an example. I thought that showing to much is showing of your security.

Excuse me if I am completely misunderstanding you or your experience level … no intent to criticize here.
The GUI for your router configuration is an application running on your router, and completely independent from your Linux computer. Your Linux computer’s firewall is an application running on your Linux computer. You can manage your local firewall on your local computer with either the Linux GUI for the firewall or with the Linux CLI. The completely separate router, though, could possibly have a CLI in addition to the GUI, or could have a programmable API; I’m only aware of its GUI.
I think what you’re seeking is a way to configure the DLINK router not through its GUI, but through a command line interface. If the router provided a CLI, you’d likely be able to reach it through an ssh session from your Linux computer’s command shell or an xterm command. I did a quick search for “dlink admin cli” and found they do have CLI capabilities on some of their routers; these are intended for connection a serial communications cable and using a terminal emulator. Not likely what you are seeking.
But, bottom line, I am not aware of any utilities that will run from the command line on your Fedora system and configure your DLINK router.

1 Like

Hey Cat. I do bridgeing. Wired Modem to Router. Want to make a forwarded DNS. I have the DHCP and the modems SSH is in check. Everything is connecting to the internet. Just wouldn’t make me type in in the Firefox browser. I did try the routers software but wont be let in by default username and PW. Thats why I want to know whats happening behind all this GUI’s

A router for home use will virtually always have DHCP enabled by default, so that your network devices connect to its network and can get assigned IP addresses. Your network devices will similarly be configured by default to get their IP address and other parameters such as DNS server via DHCP, thus provided by the router. You can override this for a particular network device by manually assigning an IP address in the router’s subnet, or setting DNS servers, etc., if the needs of that device are different than the router provides, or most likely you’ll configure the router what to tell the network devices to use for IP addresses, DNS, and so on.
If you attach a network device and it doesn’t get an IP address assigned automatically (“ip addr show” on your Fedora system, for example), then your router may have its role as DHCP server disabled.

Hey Dave. Sorry for misleading you. I’m not skilled at all and are more guessing by reading from a lot of different places and making conclusions. I really want to learn all this and I know it takes years. So thank you very much for making it much more clear.

I have a Asus router. But I just showed the D-link as an example because I didn’t know if it was a good idea to flash you security on an open forum. But even that there always is a risk of being to onest. There is allways the reward of an onest answere.

I can access the internet but do think the problem by configuring the router I do bridgeing through is making it difficult as the ethernet just pass through. I thought by reseting first modem and then router that it could be on done.