Is there any way I could fix or mitigate the blur on applications using XWayland caused by fractional scaling?

The other day I installed Fedora Workstation 38 and I’m running into a couple of problems. One of which is scaling/blurring. The default 100% scale was far too small for me to use and the 200% scale was far too large. I tried using the “large text” accessibility feature which worked well for GNOME and the default GNOME applications, but not for any other application. After searching around, pretty much every resource mentioned that you can enable fractional scaling on GNOME using:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

After restarting, I was able to select options for fractional scaling. I found 125% or 150% to be better. 125% is a bit too small and 150% is a bit too large, but I can live with it, so I chose to stick with 150%.

After scaling up to 150%, I noticed that some of my applications are now blurry. In my experience, it seems to me that this might only be happening with applications running on XWayland. One reason I believe this might be the case is because of my experience with Brave. By default, Brave uses X11. However, when I set the Preferred Ozone platform flag to “Auto” or “Wayland”, the application is no longer blurry. I still have other applications (such as Bitwarden, Standard Notes, and ElectronMail) which I assume to be running on XWayland and are still blurry. I haven’t yet installed all the applications that I’d like to use, but I’m thinking that most of them (including games) are going to be running on XWayland and are therefore going to be blurry.

Is there any way to fix or mitigate the blurriness of these applications? Or am I essentially stuck choosing between clear but tiny icons/text/etc and using blurry applications? (And on another note, is there any way I can check which applications are using XWayland vs. Wayland?)

(In case anyone suggests it, I did try posting this to GNOME Discourse, but I haven’t received any responses yet.)

UPDATE

After posting to GNOME Discourse, Fedora Discussion, r/linuxquestions, r/linux4noobs, r/gnome, and r/Fedora and waiting for about a week, I’ve only gotten one response under the post in r/Fedora. The one response I got wasn’t related to how I might be able to solve the issue or whether or not that’s possible to begin with, but instead, the user suggests that it’d be best to switch to KDE Plasma which supports fractional scaling. This seems to correspond with what other users ended up doing. For example, another user asked about the same issue on the Fedora Discussion forum and after receiving no response, they ultimately moved to KDE Plasma which seemed to work for them. However, it’s important to note that they were using X11 on Plasma rather than Wayland whereas I intend on sticking with Wayland. That being said, it looks like Plasma still has better support for fractional scaling on XWayland. As much as I loved GNOME, it just doesn’t work on some displays, as is the case with mine. That being said, it would’ve been nice if I could’ve at least gotten a response like “No, you can’t fix that on GNOME” rather than having to wait over a week with a barely functional laptop only to realize my only option is to switch to a different desktop environment.

1 Like

Without intending to cause hard feelings, it is important that you understand the only ones who may have been able to answer would have been those who had tried the same thing and failed then attempted to find a solution. The subject was fractional scaling but the title says blur.

Since everyone on forums are volunteers and answer questions on their own time and based on their own knowledge it is not surprising that no answers were received on what seems 6 different forums.

Taking an accusatory attitude with us for not providing an answer for something most of us had no clue about is hardly endearing you to members of this forum.

There have been many posts related to fractional scaling over the past few years (The first I see with a quick search was on Fedora 34) and had you even done a search on this forum you might have found several related threads.

I responded to and elaborated on many of those points in a reply over on the original post made in GNOME Discourse. The TL;DR is that my comment wasn’t meant to be directed at these communities in particular, nor was it meant to be an attack. I was just expressing frustration with the free software ecosystem (for lack of a better term) and how new users with limited time/energy/knowledge are placed in an environment where if you’re unable or unwilling to spend hours searching through dozens of wikis and forums, you’re just not good enough to be using free software and you shouldn’t express frustration with how inaccessible or fragmented things are.

If I’m understanding you correctly, you’re saying that one reason I might’ve not gotten an answer was because my title mentions “blur” rather than “fractional scaling”? Except my title includes “fractional scaling” as well as “XWayland” and it is under the gnome, wayland, and x11 (I think #XWayland wasn’t an option) tags, so I’m not sure what you mean. Maybe I’m misunderstanding. :sweat_smile:

You didn’t provide a link so I can’t be 100% sure what you’re referring to. When searching for “fractional scaling” the first result was this thread and the “solution” for it was simply to not get it working. The second result is a thread which references the previous thread and mentions Fedora 34, which I believe is probably the one you’re referencing, yet it has no replies, let alone solutions.

and had you even done a search on this forum you might have found several related threads.

Sure, there are the two previous threads I just mentioned plus the one I mentioned in my update. There are plenty of “related threads”… One of which didn’t actually have a solution and the other two received no responses, just like mine. Respectfully, it doesn’t help me to know that other people have the same problem. What would help is to have a solution, or at least have the clarity that there isn’t a fix for this issue and instead be presented with what options people can choose from. (For example, maybe the options are to use X11, or to use Wayland with either a tiny/massive UI or have blurry XWayland windows, or to switch to another DE like Plasma if that handles fractional scaling better, etc.)

In any case, I appreciate you taking the time to reply.

I have no problem replying, but I have no direct personal knowledge of the subject.

I will point out that up at the top right of the screen on this forum is the spyglass which is the search icon. Clicking it gives a box to enter the search term, and if you entered ‘fractional scaling’ it gives the various threads containing that term. The length of your title hides that term when the thread is displayed and being read so I did not see it for my earlier answer. This is the first of the list I received. The pic shows where the title is cut off.

Posting on multiple forums and in multiple threads means that those desiring to assist probably are not privy to what has been said elsewhere. It is always best to keep things on one forum, or at the least let others know there are other threads by posting links to the discussion elsewhere.

I am aware that some of those threads show ways to achieve (at least partly) fractional scaling. The only way I would have to be sure would be to go back through the many different posts and try to find answers. I suggest you try that as a starting point.

You should also be aware that sometimes the scaling that is possible on the desktop does not carry through into the app being used.

What I have done, instead of trying to use scaling is to use a larger monitor (a 42" tv helps) with 1920x1080 resolution.

The ones I mentioned? They go over how they enabled fractional scaling, but my issue doesn’t have to do with enabling fractional scaling. The issue is with having blurry XWayland windows as a result of using fractional scaling. I was just wondering if there’s anything I could do on the XWayland side of things to fix or mitigate the blur, or if there was anything I could do in general to have a better experience with fractional scaling on Wayland/XWayland, such as switching to Plasma, as one user suggested.

That’s definitely worth noting for desktop users. Unfortunately for me, changing displays aren’t an option since I’m using a laptop.

Here, I see Is there any way I could fix or mitigate the blur on applications using X.... There is an art to attracting the attention of the right subset of users.

Are you saying the title is cut off for you? It looks fine on my end using Brave. When I scroll down it cuts off at XW (in XWayland) but I don’t see how that’s a problem. It comes up when searching for it and anyone who reads the post will see the full title. I don’t control how the Discourse UI works and it’s not my fault if people don’t read what they’re replying to. :person_shrugging:

In any case, I hope the priority of this thread doesn’t turn into a discussion on how users seeking assistance need to do their best to include all of the key words in their title at the beginning because otherwise people who don’t read the titles of threads can miss it… It just seems like unnecessary deflecting. I guess I’ll try to keep it in mind in the future but that’s really not the problem here.

AFAIK Plasma supports more graphics capabilities OOTB vs Gnome. This could be due to the underlying Compositor chosen. I think Plasma likely uses KWin, whereas Gnome likely uses Weston.
[Edit] I have not tried Plasma in some time, but I have used both Enlightenment and Sway, of which I fealt Sway was more appealing (due in large part to it’s i3 heritage), but Enlightenment held it’s own. Sway did offer fractional scaling OOTB, nothing needed on my end. While the SAME hardware did not provide for it in Gnome. This is likely due to Weston Compositor intentionally not supporting all OpenGL libs since some are X specific and not needed for Wayland’s use. But are for XWayland, which is a transition focused offering for X apps that are not Wayland capable yet.