Is there a way to enable HighDPI for SDDM on Fedora Kinoite 39?

I am in the process of moving Fedora KDE Spin workstations over to Fedora Kinoite. One computer relies on two 4K monitors placed at a distance. Is there anyway to enable SDDM’s High DPI in Kinoite like it was in Feodra KDE Spin? I know the System Setting tool doesn’t work. Past forum posts about background themes give an indication that Kinoite’s SDDM configs cannot be easily changed. Is this still true and applicable to HighDPI settings. Thanks.

I would check if those settings are in /etc either sddm.conf or /etc/sddm or /etc/sddm.conf.d if so you should be able to modify them persistently since /etc is writable.

Okay, I hadn’t modified those initially. Still trying to understand rpm-ostree. After adding the following to /etc/sddm.conf

[General]
EnableHiDPI=true

There was no change. According to the Arch wiki, this step is not needed as of SDDM version 0.20 anyways.

I also tried dropping in my old sddm.conf for testing. (Even though most of it is legacy)

[Wayland]
EnableHiDPI=true
SessionCommand=/usr/share/sddm/scripts/wayland-session
SessionDir=/usr/share/wayland-sessions
SessionLogFile=.local/share/sddm/wayland-session.log
[X11]
DisplayCommand=/usr/share/sddm/scripts/Xsetup
DisplayStopCommand=/usr/share/sddm/scripts/Xstop
EnableHiDPI=true
MinimumVT=1
ServerArguments=-nolisten tcp -dpi 192
ServerPath=/usr/bin/X
SessionCommand=/usr/share/sddm/scripts/Xsession
SessionDir=/usr/share/xsessions
SessionLogFile=.local/share/sddm/xorg-session.log
UserAuthFile=.Xauthority
XauthPath=/usr/bin/xauth
XephyrPath=/usr/bin/Xephyr

Still no changes. Also tried this, but all I got was a black screen and cursor.

[General]
GreeterEnvironment=QT_SCREEN_SCALE_FACTORS=2,QT_FONT_DPI=192

Any thoughts?

I had the same problem as you, try this instead:

GreeterEnvironment=QT_WAYLAND_SHELL_INTEGRATION=layer-shell,QT_SCALE_FACTOR=2
1 Like

@ali-a Thank you, that worked! Though I did need to make one tweak because of an unexpected interaction with KDE’s System Settings’ SDDM KCM. Using QT_SCALE_FACTOR=2 and a scaled desktop made SDDM appear at 400% scale.

If scaling your desktop to 200%, do the following:

  • Log in and scale your monitor to 200% in KDE’s System Settings’ Display module (make sure it apply it)

  • Go to System Settings → Startup and Shutdown → Login Screen (SDDM), and press “Apply Plasma Settings”. Approve and type in password.

  • Lastly pull up Konsole, run sudo nano /etc/sddm.conf and add the following:

[General]
GreeterEnvironment=QT_WAYLAND_SHELL_INTEGRATION=layer-shell

If scaling you are not scaling your desktop, do the following:

  • Open up Konsole, run sudo nano /etc/sddm.conf and add the following:

[General]
GreeterEnvironment=QT_WAYLAND_SHELL_INTEGRATION=layer-shell, QT_SCALE_FACTOR=2

Thanks everyone for your help!

1 Like

Any reason this will not work in f38? I have always had issues with stability and font size on my 4K display before login screen. It occurs more frequently, yet remains random. Eg Hardrive password prompt does not always appear. Once you start typing password prompt flashes and remains constant by the time you hit enter. Text showing kernel loading and option to change remains 4pt (tiny) and hard to read.

Honestly, I don’t know about F38. I looked at the repo packages for SDDM and Plasma Desktop, they seem to be the same versions between Fedora 38 and 39. Based off that, my assumption would be that the same tricks might work. Be mindful that my rig was using Wayland for SDDM and Plasma as well as the Mesa driver stack with an AMD RX560. Your mileage may vary if you are using NVIDIA or Intel-based graphics.