Is rawhide installer ignoring installation language?

I downloaded Fedora-Silverblue-ostree-x86_64-Rawhide-20221026.n.0.iso (same result for Workstation Rawhide) and at the welcome screen of the installer, it detected my location and assumed one of the official languages of the country I am in. I changed the language to English and when I pressed the ‘Continue’ button there is a ‘unstable, pre-release software’ dialog box that appears. But it does not appear in English. It appears in the language that it had auto assumed.

I was wondering is there a way to find out if this was done on purpose? I had initially assumed it was not a bug until I read the sentence in the welcome screen, “What language would you like to use during the installation process?”

I tried the Fedora 37 Beta and that does not assume a language and if the language is changed, it actually shows the pre-release box in the appropriate language.

I believe this was one reason I moved away from a Debian-based OS (Ubuntu? Raspberry PI OS?) where you would set your language to English, but since the location is a country where English is not the official language, half the programs would be in English and the other would be in whatever location I had assigned, and some programs would have bits of both languages intermixed. Which I am just realizing that is how the installer looks like. After changing the language to English, everything in the welcome screen is in English and except the following are not in English:

  • “What language would you like to use during the installation process?”
  • “Type your search here.” (not sure if that was translated right, I’m only guessing at what it says)
  • The pre-release dialog window is not in English, nor it’s buttons.

Does anyone know if this was done on purpose or not?

If this is how it is always done on Rawhide? Or if this is how it will be done from now on, starting with Fedora 38?

I know that a lot of big corporations will just assume languages, i.e. Google will change the language for me after each page of a form I am filling out, forcing me to keep changing it. And as I said a Debian-based distro does this. And was wondering if Fedora is following suit. I really hope not…

This sounds like a bug.

Rawhide is the development release and will contain bugs that will be fixed before the next release is made. Please use the appropriate channels to discuss these issues with the Fedora QA team. They’d be able to help more:

1 Like