Invalid refspec error when trying to upgrade to Fedora 35

Hello community!

Today I got notified about a new Fedora release. :tada:

I clicked on it and then “Download”. It falied. :cry:

Translated it’s something like:

Cannot update to Fedora Linux 35. Invalid refspec ostree://fedora/35/x86_64/silverblue

Any clues on what’s happening and how to upgrade?

1 Like

No clue about why the GUI upgrade wouldn’t work, but if you’re eager enough to do the CLI upgrade instead that would be:

rpm-ostree rebase fedora:fedora/35/x86_64/silverblue

This worked fine for me yesterday.

Thanks, it seems like I had some overrides problems.

This worked:

rpm-ostree rebase fedora:fedora/35/x86_64/silverblue --uninstall rpmfusion-free-release-34-1.noarch --uninstall steam

I am getting the same error message.
It should say what the problem is and how to fix it otherwise our grandmothers won’t be able to upgrade to Fedora 35.
The error messages in GNOME Software need to be more helpful.

It seems to be a known bug: [BUG] Can't upgrade to F35 via GUI · Issue #207 · fedora-silverblue/issue-tracker · GitHub