Internet adapter shuts down only on gaming

So I have this weird issue: Wi-Fi shuts down when I’m playing games(in other words, when using GPU), whether native or with wine. I tried stress testing cpu+i/o+ram but it’s completely fine. While gaming, the Internet adapter just disappears, can’t wake it up manually, and restarting NetworkManager can’t pick it up. At first, I thought it was Nvidia related problem, but after disabling it, I’m still having issues with the internal GPU. Temps are not so high too, so that’s not a problem. So at this point, I was so sure it was hardware related issue that I started looking for a new laptop(the adapter is soldered on the motherboard) but then I installed windows to just make sure it was a hardware issue, but Windows has no problems.

machine: Asus tuf A15
os: fedora 36. no special repos enabled.
adapter: Realtek RTL8822CE.
kernel: I tried several different kernels, I guess its not kernel related

recent package upgrades that the system did: libass, sane-backends, python3-regex, annobin, remove-retired-packages-37.2-1.fc36.noarch, ibus-typing-booster,vim-data.

And before that was a huge update on 07 Dec: KDE-related packages to 5.26.4-1, wine-related packages to 7.22-2, and KDE apps to 22.08.3 (about 150 packages upgraded). I don’t remember if this is the time system started acting like this. But anyway I can’t roll back to it cuz I don’t have them locally and fedora doesn’t have those older packages anymore. It is too much work to manually downgrade 150-200 packages.

so here are the logs:
inxi doesn’t show wifi adapter at all.

nmcli m:

chxei_5G: connection profile changed
wlp3s0: connection failed
Networkmanager is now in the 'disconnected' state
There's no primary connection
wlp3s0: disconnected
Connectivity is now 'limited'
Connectivity is now 'none'
wlp3s0: unmanaged
wlp3s0: device removed

sudo ip link set wlp3s0 up

sudo ip link set wlp3s0 up
Cannot find device "wlp3s0" 

I was looking dmesg and everything started to fail after this:
[ 5880.109058] rtw_8822ce 0000:03:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x000d address=0xaebf2014 flags=0x0000]

A quick internet search seems to suggest this is a pretty old and well-known issue with that Realtek adapter; have you looked into this?

1 Like

I reverted kernel-headers to 6.0.8-xanmod to 6.05 stock. At first boot, it seemed fine. It is odd, could headers make such a bug? I’m almost sure the problem didn’t occur instantly after xanmod kernel update.

I installed your suggested module and restarted. It is still fine.
if the problem doesn’t reoccur then I will reinstall all kernel packages (that should remove Realtek module right?) to find out which of these fixed my problem.

Interesting… I don’t know enough about kernel development to speak to if headers could cause the bug.

I’ll keep fingers crossed for you during the debug process…

I reinstalled kernel packages yesterday and still no issue. Looks like it was caused by linux-headers package. strange.

If using a non-mainline header and kernel package then certainly problems may be encountered, especially if using an app that is built explicitly for use with the mainline kernel and matching libraries.

The wifi driver was built for the mainline kernel and probably failed with options in the xanmod kernel.

I would think that at first but the problem was rather strange, it only occurred in gaming scenarios. Which is… weird. The first thing that came to mind was hardware issues and digging latest updates. Cause it is not the first time wifi failed on fedora. Its 3rd time tbh. Previous 2 were caused by a firmware package update. I had to roll back firmware and exclude it from updates until next release to fix that issue.

Anyways, thanks for your response. I will keep this in mind.