Installition from Live Workstation not booting due to strange partitioning

I try to install Fedora Workstation 40 on a Dell Precision 3630. I have run Fedora on it before, but the SSD broke and I need to reinstall. However, when I do an automatic install it will not boot. The bios do not find anything bootable.

Looking with parted I have:

liveuser@localhost-live:~$ sudo parted /dev/nvme0n1
GNU Parted 3.6
Using /dev/nvme0n1
Welcome to GNU Parted! Type ‘help’ to view a list of commands.
(parted) p
Model: WD Blue SN580 250GB (nvme)
Disk /dev/nvme0n1: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: pmbr_boot

Number Start End Size File system Name Flags
1 1049kB 2097kB 1049kB bios_grub
2 2097kB 1076MB 1074MB ext4 bls_boot
3 1076MB 250GB 249GB btrfs

Comparing this with a laptop, also that with a nvme SSD i have:

Modell: THNSF5256GPUK TOSHIBA (nvme)
Disk /dev/nvme0n1: 256GB
Sektorstorlek (logisk/fysisk): 512B/512B
Partitionstabell: gpt
Diskflaggor:

Nummer Början Slut Storlek Filsystem Namn Flaggor
1 1049kB 630MB 629MB fat32 EFI System Partition startbar, esp
2 630MB 1704MB 1074MB ext4
3 1704MB 256GB 254GB btrfs

Why does not my automatic installation add an EFI partition?

Any suggestions?

The ESP is supposed to be on /boot/efi so you end up with /boot, /boot/efi

  • Do you have SecureBoot
  • Are you Dual Booting this machine?

It looks like you booted the installer in legacy (MBR) mode so fedora was installed in legacy mode.
You will need to reinstall after booting the installation media into uefi mode. I find it simplest to set the bios to boot uefi only then I never need to worry about selecting the proper boot mode.

Are you saying the installation choose what boot it install on how I boot the usb installation media?

I’m not sure I can boot it in uefi, the bios let me choose between legacy external on uefi internal.

No access to the box right now, but I see if I can boot the installation in uefi tonight.

Most systems that have CSM enabled in the bios will automatically boot in legacy mode unless the user selects to use uefi mode during boot.

When booting a live media by USB I use the boot menu (F11 on my keyboard) and then select the uefi version of the usb device for booting. When the bios is set to boot uefi only that selection is not required.

2 Likes

You were completely correct! I was able to boot the live usb in uefi mode and then the installation produced a bootable system!

However, when I boot the live iso in UEFI my ssd is not visible. No /dev/nvme… I know the installation worked because I installed it on a traditional HD.

The ssd is still not visible when I boot the newly installed system. Any ideas on that?

Anyway, many thanks on help with the UEFI/legacy boot problem!

It turned out that Fedora Live use the boot mode from the usb iso to decide what to install on the disk. Booting it in UEFI mode solved it.

However, as I wrote to Jeff V who gave me that insight, there is a new problem as the ssd is not visible when booting with UEFI.

Check if the BIOS has the drive in AHCI mode.

That was the problem!
Thanks!