Installing Wayland in Fedora 31 Server

I installed Fedora 31 Server and it seems to be behaving as expected.

I’d like to have a GUI. I read about Wayland (and Weston as the reference implementation), so I thought I’d try it.

I logged into my Fedora 31 Server as root and did:
dnf install weston

It installed a bunch of other required packages and completed without error.

But when I do a weston-launch it fails to start. Subsequent to trying weston-launch I created ~/.config/weston.ini with content as below, then tried doing weston-launch from the command-line again. I’m running weston-launch as a non-super-user.


This was based on this Fedora Documentation link.

Any suggestions on how I can get Wayland running on Fedora 31 Server?

Thank you. :slight_smile:

Hello @medicaldemocrat
And welcome to the community. If you haven’t done so already, please take the time to review the getting started guide for the forum.

I run Silverblue so Wayland is already up and running for me. But I would start with the System Administrators Guide and in particular the topic on Wayland to find your answers.

Let me know if you still need assistance from there, I’ll check back here later this evening.



Thanks @jakfrost .

I thought about using Silver Blue 31 but when I tried it with 30, it had no dnf and it was so unfamiliar that I went back to Server for 31. Do you have dnf in SB31?

On Silverblue it uses rpm-ostree as the package manager, which uses libdnf. Because it is derived from ostree, you can use ostree commands to query remotes (repo’s) about their package content, also use ostree to add remotes (repo’s). A lot of apps are available as flatpaks either through fedora’s flatpak repo or flathub’s, and there are other repos out there. I find I need to layer some packages onto silverblue for my use case (rpm-ostree install <package>), and some I am able use as flatpaks right OOTB. Failing that, if I need to really modify my environment and install beyond my comfort zone to tackle a dev problem, I use toolbox containers since I am not as concerned about trashing a container setup as I am about my core system.

1 Like

Thanks again @jakfrost.

I just reread the wikipedia article on Fedora, in particular on Silverblue: " Silverblue, focused on an immutable desktop specialized to container-based workflows and IoT , focused on IoT devices"

I guess that would explain why there was no dnf. Apologize for the silly question above. Thanks for explaining your setup. I read more about Silverblue at Fedora Silverblue User Guide :: Fedora Docs and confirmed my guess below, that it’s designed as a Desktop/Workstation OS.

I’m trying to make my box into a server, but I still plan to use it from the display too (which is why I’d like a GUI). Are you using your box strictly as a Desktop/Workstation or are you using it as a server too? If the latter, are you accomplishing server functionality strictly with containers (I guess you must be)? I would like to learn more about containers (which is why I tried Silverblue 30), so maybe I should just toss this Fedora Server 31 installation and install Silverblue 31. But I’m concerned about a steep learning curve for accomplishing basic things like I’m accustomed to doing in a typical (non-immutable) OS. Other than Fedora Silverblue User Guide :: Fedora Docs have you found a good introduction to Silverblue (and immutable OSes in general)?

I know I may be getting off-topic with this line of discussion. Hopefully OT rules are not so strictly enforced in this community? Please pardon my digression if I’m wrong on that.

I have, and sometimes still do set up servers on my system. I’m one of the moderators so I can turn a blind-eye while we get OT, digress away.:wink:
As for a quick intro, I’ll take the liberty of directing you here, It’s a bit dated, and some things have changed a little, but it does give you a good run through of the main technologies. I’m sure @miabbott won’t mind. :grin:
Sort of off topic, but not, I have been doing some poking around Quarkus, which quoting from their site is …

A Kubernetes Native Java stack tailored for OpenJDK HotSpot and GraalVM, crafted from the best of breed Java libraries and standards.

With it I can develop an app in Java using their framework, maven, and GraalVM, then deploy to container for running as a server exposing ports for the container, as either an executable jar or as native code. Pretty cool stuff if you ask me. Plus I can use my Netbean IDE flatpak to modify the project, while compiling and running the app with Quarkus in dev mode, and seeing the result as I change things. Definitely real cool that.
The nice thing about containers on Silverblue is that they are daemonless (via podman) unlike Docker, so you don’t have to be root to create them, any user can. This makes them more secure being daemonless. If your not going to be using the server as a production thing, Silverblue should be fine. There are people in the community currently doing what you are asking about.
Plus there are resources for rpm-ostree and ostree, worth reading. And don’t forget Flatpak.

1 Like

Thanks for permission to digress away. :slight_smile:

Despite the fact that I do see many advantages to Silverblue, for this box in particular, I do need a production server, so I’ve decided to stick with this Fedora 31 installation.

Having seen no replies here on how to get wayland (weston) running in Fedora 31 Server (the System Admin Guide assumes it’s already running: “Wayland is enabled by default in the GNOME Desktop”), I posted a bug. If I see some resolution there I’ll share it in this thread too.

Thanks for the warm welcome to the community @jakfrost and for sharing your experience with Silverblue. I do see myself using that as a daily driver at some point, but not quite yet. :slight_smile:

Hi again @jakfrost et. al.

Gerd Pokorra very kindly helped me solve this problem. Thank you Gerd! I think it was a bug with dependencies: mesa-dri-drivers apparently did not get automatically installed when I did sudo dnf install weston and I guess it should have been?

Now, on a related note (or should I mark this issue as resolved and post my next question in a separate thread?), why is it the case that when I do sudo dnf install gdm dnf wants to pull in a bunch of xorg-x11 packages as dependencies?

I would think that with weston installed (and even running! thanks to Gerd! :smiley: ), that would meet any compositor dependency requirements such that gdm would not need to pull in xorg-x11 packages.

Or perhaps that’s because this is F31 Server and the dependencies for Server (for things like X and Wayland and gdm) are not up-to-date for the Server Edition (I’m assuming here that F31 Desktop Edition would not do the same thing; but then again, F31 already has weston installed out-of-the-box so maybe that dependency issue never comes up for Desktop Edition?)?

If I should resolve this thread and post my gdm questions in another thread please let me know and I’ll do so. Thanks again for everyone’s help!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.