Installing teamviewer on fedora 33

HI there,

Just wondering if anyone has installed teamviewer on fedora 33

or perhaps if there are any alternatives to teamviewer that works with windows to linux and linux to windows/macosx

I have tried installing but I get errors…


1 Like

Yea, that’s an issue, which I have noticed on my F34, if I check updates.
I haven’t had time to check the prob.

Maybe as temporarly solution you can install Teamviewer due Flatpak.

1 Like


The command should be:

sudo dnf -y install teamviewer.x86_64.rpm

Thanks Tom.


yep :wink:

here the link to download it … it seams to be an 404 the error you posted.

1 Like

Yes, there is an alternative: “anydesk”
it works on linux [1], windows, Mac, android, … and is significant smaller then teamviewer (win binaries: factor 10)

anydesk has the same developer as teamviewer has/had

on F32 (F33 ???) you can fetch the rpm.
onward from > F32 you need anydesk from flatpak, cause of missing graphic lib or such to run the rpm-version

on F33 or F34 I sometimes noticed that flatpak-anydesk doesn’t end itself when shutting it off (see sys-monitor)

the file transfer is somewhat un-handy…, but it works.


Ah cool thanks,

Do they have a free version like teamviewer?

Thanks a lot for your help.

it worked any now I can download it, and it runs great.

So why did i need the -y before the word install in the command ?

also I get this error now when I update

1 Like

It is not an error … it is an information that “failovermethod” is not valid. Check the file mentioned in the Message and try to make # in front of failovermethod=priority like this # failovermethod=priority and see if you get the message again.


Thanks a lot, its gone now. I had a feeling I should have done that but was worried it might not be correct.

I am just wondering why when i run sudo dnf update it does not update the apps in the filesystem I have.

But when i goto to the software centre it wants me to update them. See below…

I would like to know how to do this from the terminal as the software centre doesnt seem to update them

1 Like

up to now it’s free for personal use

first I need to say: I’m not using software center.

But what I know:

  • dnf update lives under /var/cache/dnf
  • software center lives under /var/cache/packageKit or a similar naming

they should be synchron [1]
to check that compare the enabled repos under software center with what you get from

grep enabled=1 /etc/yum.repos.d/*


sudo dnf update --refresh

and the refresh button in software center should give the same output e.g. the same packages needing updates.

1 Like

see: man dnf

1 Like

great thanks I executed that command and i got the following output

And then i ran update but the software centre didnt get updated.

do you see in software center a big update ~600MB or so named “OS…” ?

if yes: run in an terminal

sudo flatpak update

after that run an refresh in the software center ( the circular arrow in the top bar)

1 Like

Yes it worked thanks a million @sixpack13.

Your are such great help.
I am making notes of these commands in my book.

I did run into this error though…

Sorry for all the questions.

Also is there a simple way to do a backup like with time shift or something similar in-case I need to do a rollback?

I wanted to install “Snapper” so I could rollback in GRUB menu should an update damage some features/hardware drivers but I was very confused on the steps

for the dnf case: please read “man dnf” (keywords “history”)
for the flatpak case: no idea

FWIW, I’m maintaining a package of teamviewer for myself here: teamviewer.spec · master · Greysector / RPMs / teamviewer · GitLab . The SELinux policy is unsafe, but it works. Patches welcome. :slight_smile:

1 Like

Thats really great to know thanks a lot