Installing Fedora on a HP envy x360


I’m currently trying to install Fedora on my new laptop (HP ENVY x360 15-ed0768ng) next to Windows 10. In order to get Fedora working I did following:

  • Installed gparted on a usb in order to partition the disk 500 GB
  • set secure boot on “disabled”
  • rebooted
  • gparted started and the start screen appeared. pressed enter to start gparted live
  • hung. nothing happened. no repsonse.
  • I tried all the other gparted live versions but with no result at all

I also did try to partition the disk with clonezilla, but the result was the same: nothing happened.

Does anyone have an idee what to do next?



Have you looked as using windows 10’s diskpart?

Thanks Tom.

yes I did also try to do that. I made a 200 GB partition in Windows, but when I try to install Fedora from the USB, Fedora only shows me the 500 GB disk…

I couldn’t find SATA mode nor AHCI…

Update the BIOS/EFI firmware to the latest version.
The SATA mode can be labeled as RAID, or Intel RST, or Intel Rapid Storage Technology.
You should disable all of them if you see any, and switch to AHCI if possible.

1 Like

Hi vgaetera,

I did find the RAI under Configuaration, but I can’t switch it nor disable it. it says: no disks connected to system…

1 Like

when I try to install Fedora from the USB to the 200 GiB partition I made, I get following error:
Failed to find a suitable stage1 device: EFI System Partition must be mounted on one of /boot/efi.;EFI System Partion cannot be of type None.; …

What to do next??

That tells you you need an efi partition.

If installing beside windows, and windows was installed with UEFI boot, then use custom install and mount the existing efi partition at /boot/efi as it says. If you are planning to use BTRFS or LVM then you will also need a small (~500 MB) partition as ext4 to mount at /boot.

What I would suggest, and it has worked for several people here, is to remove the 200G partition you created, then install in auto-partitioning mode. The installer will create its own partitions in the empty space and will automatically create /boot and use the existing efi partition as /boot/efi.


Thanks a lot computersavvy!!! it works !!!

1 Like

The torture never stops… Now, fedora is running fine, but does not find a WiFi Adapter it says. Since the laptop only comes with WiFi, I cannot connect to the internet.

when I type “lspci” in the terminal, I get following response:
00:14.3 Networ controller: Intel Corporatio Killer Wi-Fi 6 AX1650i 160 MHz Wireless Network Adapter (201NGW) (rev 30)

Anyone with an idea???

As i run Fedora from the USB stick, the WiFi did work strangely… I installed Fedora from the USB…

after rebooting WiFi suddenly shows up and I can connect to my network. Strange…

Not really strange. From the live USB there are limited options for drivers and once installed those limits are lifted.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.