Installing Fedora on a Dell Latitude 7490

Has anyone had any success installing Fedora on a Dell Latitude laptop, specifically a 7490? Installs fine on my Lenovo Thinkpad T490 but not on the Dell. Thanks.

See if this helps:
Installing Debian On Dell Latitude 7490
I would try first WITHOUT disabling “safe boot” then if it doens’t work, proceed to disable.

Firstly Welcome to Fedora :handshake:t5: :fedora:

Can you be more specific? What’s not working?

My guess is the installer doesn’t see the SSD (or disk, not sure).
Like:
“System Configuration: SATA Operation: change “RAID On” to “AHCI”. Without this change, Linux won’t find the internal hard disk.”

Fedora 40 would not even boot up from a USB stick. Fedora 39 allowed me to get to the partitioning screen. Accepted the sda ext4 location to install on. Set up a separate EFI partition for the install but could not check the Reformat box on the right side of the screen because it was grayed out.

Otherwise, I have installed Mint 21.3, LMDE6 and Ubuntu 24.04 on the Dell Latitude 7490 with no problems. Dell states on their website that the 7490 is only guaranteed to install on Ubuntu and I assume Ubuntu and Debian derivatives.

Oh ok, I do have a Dell too and it came with Ubuntu preinstalled.
When I tried to install anything else I had to disable “fast boot”, whatever it was.
It makes no sense you cannot install Fedora but it works with Debian and alike. I would like to know why.
On my Dell Inspiron Fedora works better than both Debian and Ubuntu, meaning it never gave me any problem with hardware and even peripherals.
Anyway, well, in the worst scenario at least you can install some “linux”.

I think there might be a flaw in these steps, but I’m having trouble picturing it. I would need to see it. . . Hmm. :thinking:

Also, could you try one of the spins ?

https://fedoraproject.org/spins/

Rick, have you tried to display the boot sequence in the text instead of the standard “doingsomethingrotatingthingy”?

I think in Fedora you press “esc” as soon as it starts.

I don’t think the USB does nothing at all, probably it fails and stops at some point and the verbose boot should tell you where.

The partitioning and the boot loader placing in EFI is a whole different story. Do you have other installed Operating Systems?
In my Dell the BIOS shows a list of bootable OSes by pressing f12 and allows to delete entries somewhere among all the BIOS settins by pressing f2.
Have you checked what the BIOS shows?

I do have Mint 21.3, LMDE6 and Ubuntu 24.04 installed on this Dell Latitude 7490 and all are running fine. I completely removed snapd from Ubuntu. 24.04. I have been in and out of BIOS many times on both of my main laptops.

I will try all the recommendations in this thread. But I won’t be able to do that for a few days because of other commitments. After additional testing I will report back on this thread. Thanks.

1 Like

“fast boot” is essentially hibernation – it stores the running OS state to disk and reloads it without the overhead of a full boot, but you can only load the OS state that was saved.

I installed Fedora 38 on a Dell Latitude laptop, although I can’t recall the exact model. The installation was initially unsuccessful because the installer hung. This guide might be helpful.

You can press Esc to modify the kernel arguments during boot.

I made the changes siggested in this thread. Fedora 40 finally allowed me to load the OS and get to the partitioning screen. Accepted the sda ext4 location to install on. I again set up a separate EFI partition for the install but could not check the Reformat box on the right side of the screen because it was grayed out. I had the exact same results with Fedora 39 and 38. Since I couldn’t check the Reformat box I received an error saying I needed to set up a biosboot partition for the install. Never heard of anything like that before.

I have never had so much trouble trying to install a Red Hat based distro. The Anaconda installer is very dated and awkward and needs to be changed to something simpler like the Calamares installer which is simplicity at its best.

Unless someone has any additional ideas I will simply have to be content with Ubuntu/Debian derivatives on my Dell Latitude, whereas my Lenovo Thinkpad is much more flexible with installing other distros. Thanks to all.

So I have Fedora Plasma installed on my Latitude 7480. Not a 7490, true, but I have to think it is close in specs.
I do recall there were some required changes in the BIOS. I don’t exactly remember what I changed since it’s been a year since I bought it (less than $300 via Dell refurb; amazing deal) but I can at least document what I have set and perhaps you could compare? Would that help?

What Fedora release did you install?

Please let me know how your BIOS is set up with all pertinent specs.

Also how you specified on the Fedora partitioning screen for the partition to install on as well as the EFI System Partition to boot from. If you could include some screenshots of the Anaconda partitioning screen that would be helpful. Thanks.

Is sda the internal SATA SSD? Was there an existing EFI partition? Normally, the EFI partition is the first partition on the disk and formatted as FAT with a GUID C12A7328-F81F-11D2-BA4B-00A0C93EC93B. By “a separate EFI partition for the install” do you mean a second EFI partition on a disk that already has and EFI partition used by another OS, or a partition other than the linux system partition?

For a first Fedora install it is generally best to stick with the installer’s defaults so you can focus on any hardware issues, then once you have Fedora working you can consider tweaking the configuration. On new hardware I often do the first install on a small (128 or 256 GB) USB3 SSD (small drives removed from Windows laptops that needed more space are cheap). It can be useful to have an alternate bootable system for troubleshooting a system that fails to boot or has issues with an update, and you can test-drive F41 without messing with your main F40 installation.

Yes, sda is the internal 2 TB SSD. I bought this laptop with Mint 21.3 as the only installed distro. No Win-doze. I have 2 EFI System Partitions on my Thinkpad T490: One for Mint 21.3, LMDE6 and Ubuntu 24.04; and the other one for Fedora 40. Everything on the Thinkpad runs well including Fedora which installed without a hitch. I created a second system partition for Fedora based on what I read online. Being that I already have 3 other distros installed on my Dell, I am trying to use the manual partitioning method.

I have attached a screenshot showing my disk layout, including the two partitions I created for the Fedora install. I hope all this info. helps to find a solution. Thanks.

At the time when I first received the laptop would have been Fedora 38 Plasma. I’ve since, also, wiped it and installed NixOS. But that didn’t stick for very long and then I installed Fedora 39 Plasma and since upgraded to Fedora 40 Plasma.
I took photos of the important sections, it was easier.







If you have questions about a specific section from these photos, or an area I did not include, please let me know.

I think this is important to note as well. . . Could be an issue with how things are being set up.

I followed Edward Crosby’s solution from May 19 which included several screenshots of how his BIOS is set up on his Dell Latitude 7480 which is close to my 7490. I also changed the separate EFI System Partition I set up for Fedora 40 from a FAT 32 file to a FAT 16 file which is what I have on my Lenovo Thinkpad 490 where I installed Fedora 39 without a hitch.

I loaded the Fedora 40 USB flash drive again. When I got to the partitioning screen I did the same thing as before. Only this time when I specified the EFI System Partition the area on the right side of the screen was no longer grayed out. I was then able to complete the installation and took several hours today to load additional packages and all my data files.

I wish to thank everyone here who put forth effort to help me solve this problem. It proves what a dynamic community Fedora has! :grinning:

1 Like