Installing Fedora (Dual-Boot) onto HP Laptop 17-by0086cl

I had an embarrassing time yesterday while attempting a Fedora installation on a colleague’s machine. :cold_sweat:

Short Version:
I didn’t do it – I rescheduled the exercise until I fully understand the situation. Anaconda was not detecting the drive. It shipped with an Intel Rapid Storage Tech RAID volume setup. Windows-10 (OEM, default) and Fedora live-media booted fine.

Long Version:
The machine specifications? → [Here]
I tried the suggestion on this page. I got stuck at #5 – the BIOS offers no easy way to switch to AHCI without disabling the volume first – or was that the idea? An attempt to disable the volume posted a message suggesting that I would lose data (though there was a toggle to preserve – couldn’t risk it). I also tried the following after booting the live media:

mdadm --auto-detect -v

That executed silently. Log messages (dmesg) seemed to suggest that it was conclusive. Although, I couldn’t find “–auto-detect” in “man mdadm”. Anaconda still could not see any drives afterwards.

Has anyone been through this path before? I’ll appreciate some guidance

I’m quite sure RAID in question is not something mdadm can understand or work with – as with motherboard provided RAID Windows uses sometimes.

We already had a similar question here (it was about HP laptop too if memory serves) – and after switching to AHCI installer saw the drives ok. Poster of that question wasn’t interested in keeping Windows though.

I can offer no advice about switching off Intel RAID without losing data, maybe someone else has the experience.

Edit: I actually seem to be wrong with my first statement, these two links at least have something to say about mdadm and Intel RAID or so-called “fake RAID”:

I can’t say if they apply to Intel RAID implementation on this notebook or some previous version though.

@nightromantic is right here, but to go a bit further: Linux in general flat-out does not generally support booting to software RAIDs like this. I believe it can work without data loss in most cases, but you might want to ask the colleague if they were explicitly using the RAID for anything or if it was just a default toggle that they ignored.

The steps to safely switch to AHCI with Windows 10 installed are here.

1 Like

Not different from the suggestion I tried … see second URL in the initial post. Similarly, I paused at step-4 (which corresponds to step-5 in the resource I followed)

I am certain that my colleague received the machine in this state (very likely from the vendor). He is oblivious of RAID. I have also wondered if creating media from the Restore Partition will suffice for re-installation in the event that loss becomes inevitable.

Ah whoops, so I believe if the steps are performed properly and you don’t delete any of the volumes, then you should be able to switch over. At minimum, I’ve walked several people on Discord through similar steps, and nothing’s broken yet.

Out of curiosity, what system do they have? It may be a little easier to find a definitive answer knowing that.

@refi64, I believe answer to this question was provided in the first post too:

I’ve seen some references that if the system contains just one physical drive (i.e. no actual raid) then this change should lead to no data loss – though I have no actual experience to confirm this myself, so please take this with a grain of salt.

I have some experience with HPs here, and I strongly believe that it would suffice with two caveats: after restoration from such a medium you’ll get notebook in the state before it’s first boot/first launch, so:

  1. You need to save all the owners files/data already on this machine.

  2. You’ll need to be ready to reinstall any additional software that was added to the machine afterwards.

That’s obvious, I just pointing it out so it wouldn’t slip your mind.

Also HP usually (always?) contains a special tool to create a rescue medium (and that tool can only be used to create one such medium, doh!) – I think it’ll be better to use this tool over windows built-in or some third-party ones.

Finally gained access to the machine again today.
I created a RECOVERY Disk alright but the conversion went smoothly – no loss of data – so I didn’t get to use it. I only needed to trust HP’s provision eventually (the ‘preserve’ toggle)

1 Like

Yea, congratulations on successful operation!

By the way, I suggest to mark @refi64’s post:

as a solution, it was a real answer to your problem, all the other posts (mine included) were just clarification, not the real solution.

done … although those suggestions were already implied in the initiating question. I was just skeptical

1 Like

I personally would be skeptical too )) It’s good we can ask advice from one another here ))

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.