Installing Fedora 40 on 2012 MacBook Air - crashes

Upgrade to F37 successful!

Weirdly it seem to run 6.5 kernel without much problem: HW probe of Apple MacBookAir4,1 #7ede1c369c

Strike that last comment - locked up after a minute or so.

Probed with 5.15: HW probe of Apple MacBookAir4,1 #07fc93b0b9

Managed to upgrade to F39 - but kernel-longterm with 5.15 is only built for F38 - so that path starts to be a bit shaky.

Up to F40 now running on a 5.15 kernel built for F38. Not the most “production grade” setup in the world. :wink:

1 Like

If the 5.15 kernel works reliably, you can try the latest 6.8 kernel. If (when?) it fails, reboot to 5.15 and use journalctl -b -1 to look for details.

There are some LHDB Probes for MacBookAir4,1. A couple used 6.x kernels. A quick scan for hardware differences shows all using the Core i7-2677M CPU but different flash/SSD drives in each scan. Apple often uses drives with custom firmware (thermal and power management), so some 3rd party drives may have issues. It would be interesting to see if F40 has problems using an external USB3 drive. Having a second full Linux bootable system give you more options than the Live USB installer when troubleshooting.

So I guess I should physically remove the drive before expecting the install to USB to work?

Have tried started the F40 installer with it in to install to USB (unsure if USB3 though) - but lockups prevent that from working.

You should not need to remove the internal drive to install Fedora on a USB drive – I’ve been doing that with Apple Intel systems for a couple decades – just be careful that you have selected the USB drive for the install.

Boot failed before I got to the login screen - but I don’t catch why when reading the output from journalctl.

We had problems with encrypted Disk on Nvidia. The resolution was to big and the pw-field was not shown. But blind it was possible to enter the password for the encryption and afterwards it continued.

Could it be that you have something similar? Do you see a black screen?

You can forget the above if you still can unlock the encryption.

Without a gui can you login (Pressing ctrl & alt F3,F4 etc. )?

No, that’s not it. I get the luks password prompt. What I meant with my comment was that linux locked up very soon after unlocking the encryption - and as such the output from journalctl does not contain much more than the boot.

The time before lockup is somewhat random, so if I try again I might be able to login and open a terminal and run a few commands. I think the log in the gist is better than such an example as there is less noise from the DE.

I’ve seen lockups before the GUI starts.

This caught my attention:

kernel: i915 0000:00:02.0: [drm] Skipping intel_backlight registration

There have been reports other i915 Intel graphics laptop systems of the internal monitor going black but external monitors work. Here, on an iMac with 6.8.9 kernel:

% ls /sys/class/backlight
acpi_video0@

Desktops don’t have anything in /sys/class/backlight, but iMac is essentially laptop hardware in a different form.

Older kernels have: intel_backlight.

Do you have an external monitor (one that works with earlier kernels) you can use to see if the system is trying to use an external display?

When the screen locks up it does not turn blank - whatever it was showing is just stuck there.

My MacBook Air does not have any external monitor ports - so unable to test with external monitor unless I find an external adapter.

On the working kernel I have intel_backlight:

$ ls /sys/class/backlight/
acpi_video0  intel_backlight

Not much to switch off.

While I have Fedora 40 installed on my Alienware gaming laptop, I went to eventually installing Mabox Linux (Manjaro-based using the Openbox window manager) on my mid 2011 MacBook Air with great success. It’s on kernel 6.8.8 at the moment.

Inspired by this I tried installing Manjaro with xfce - that installer freezes as well:

Interestingly it got stuck just after getting some battery notifications.

Yesterday I tried the 6.8 kernel in Fedora and it seemed a lot more stable than before - until I removed the power cord after which it froze almost immediately.

Maybe there is a connection, maybe it is when some signalling about running on battery fires that I get the freeze?

This is looking like a power issue. Newer kernels do more so may have higher peak power needs. You may have a weak battery and/or failed power supply components such as electrolytic capacitors. Some laptop systems need a good battery to meet peak power demands. I gather this system was not used for a prolonged period. I recall schools having problems with Apple laptops left on a shelf over the summer break. They had to arrange a way to keep them charged. Electrolytic capacitors can deteriorate when not used, yours may be improving with use.

There are many command-line tools that report power usage and battery status on linux laptops, but I have no recent experience with them.

Yes that is also what I see. On my F40 under settings i do have a Performance option. As I do see on @azzid 's screenshot he not has it available.

As he uses the Balanced option it might changes to Power Saver mode while removing the Power Cord.

@azzid please try the Power Saver option while using the Power Cord and see if you get immediate troubles.

Intrigued by your reply I re-installed F31 (with kernel 5.8) and punished it with stress.

Left it running for an hour or so. Computer got warm to the touch and fans blasted like they were ready for takeoff - but no lockups.

I saw the powertop report system baseline power up to around 20W.

Kwizart was friendly and capable enough to ensure there are packages of kernel 5.15 for F39-40 as well, so now with the copr repo enabled I’m able to run upgrades without landing on a 6+ kernel - which seem to work fine!

1 Like

After the Mandriva test I re-installed F31 and went through another round of upgrades. Somewhat interestingly I found that F33 - which is the last one with a natively non-crashing kernel is also the last in the update chain to not have the ability to select power profile. I.e:

F33

F35

So, as we’ve stated before in this thread the issue seem to correlate with advanced power settings - I still have a hard time accepting hardware as the source of the issue though as stress was unable to bring the machine to crash on 5.x kernel.

Other than the gnome power-settings - is there some lower level way to stop exercising the power optimization code in the kernel that the power profile settings relate to?

Normally this is done in Bios. Give us a inxi -Fzx from your hardware, to see what kind of Processor you are using.