Installing Fedora 40 on 2012 MacBook Air - crashes

I have a vintage macbook air from 2012 which I’d like to run linux on.

I’ve tried installing Fedora 40 - but never got to 100% of writing stuff to disk.
I’ve tried xubuntu 24.04 with similar results.

Broken hardware you say? I’m not so sure.
Installing LiteOS6.6 works fine.
It is based on Ubuntu 20.04 - so quite old kernel in comparison.

My best guess is that there is some regression in modern linux causing this. Seemingly at random.

How would one go about tracing what happens before the crash? Only hard reset works after the machine gets stuck. It’s no graceful crash - everything just freezes.

You could try under Fedora an older LTS Kernel to be on the level of liteos:
https://copr.fedorainfracloud.org/coprs/fulltext/?fulltext=kwizart

Are you installing to the internal “flash storage”? Are you planning to keep MacOS?

Few of the original Apple flash storage (early SSD) devices used the Macbook Air still work, and linux installs may push an old device to failure.

I run Fedora 40 on a late-2012 iMac using an external USB3 drive case with a 128GB
SSD (pulled from a Windows box when the SSD was upgraded).

Using the Live Fedora Workstation installer you should check the SSD/flash storage health
using Gnome Disks.

Check reports for your model in the LHDB.

Aight, good idea! Liteos is a spin on Ubuntu 20.04, which seem to run Kernel 5.4 - which I guess would correlate to Fedora 31? :astonished:

Currently downloading

Machine was not all that well when I first dusted it off to install Linux, so I’ve already replaced the drive with a Brand New™ off Ali Express:

Screenshot 2024-05-12 at 20.44.54

Nope, no MacOS to preserve - disk is clean.

Not all that easy to correlate the MacbookAir numbering on LHDB with the actual computer. Printed on the chassis is Model A1370 - that does not correlate to anything I find on LHDB.
I found this which look similar. Curiously also on kernel 5.4.

Installed without a hitch.


:exploding_head: :exploding_head: :exploding_head:

Was able to do a hw-probe: HW probe of Apple MacBookAir4,1 #6ce2799571

Still works after upgrade to Fedora 33: HW probe of Apple MacBookAir4,1 #f28302a3ec

1 Like

Keep Going :muscle:t5: You have 7 more releases to go :bullettrain_side: :dash:

1 Like

Would it not be easy if you just check the live isos ? Or do they work all?

Even the Fedora 40 live iso works some arbitrary amount of time before it triggers the lockup.
If I leave it running without actually letting it start to copy data it still locks up after a while.

Also, downloading and “burning” the isos takes about the same amount of time as letting Software do its thing. :wink:

I guess it has to do with the power savings. Have you tried to switch them totally of to see if the crash still occurs ?

Btw … are you testing the Workstation? Or an other Spin / Eddition ?

1 Like

Don’t know how to do that. Seem particularly hard in the installer?
How would you have me do it?

I’m testing Workstation.

After upgrading to Fedora 35 computer locked up before I was able to type my password.
Unlocking encryption and activating the password prompt worked, so it got a few seconds. :wink:

Reverting to the kernel from Fedora 33 (5.14.18) seem to work.
The non-working kernel is version 6.0.12.

So the issue seem to be as old as kernel 6.

Did you jump from F33 > F35 ?

Here is a weird suggestion, If the F33/F34 kernel worked, Go back to F33, do the upgrade in place to F40 but boot in with the F33 kernel ?

1 Like

Per the recommendations in Software. I did not force the skip of F34, it’s the default.
F31 upgraded to F33 directly as well.
F35 wants to upgrade directly to F37 - will need to apply that using the 5.14 kernel…

1 Like

Above I gave you the link to the LTS kernels. I meant that you get to an running state and install them to easier test between working and nonworking kernel and try to play with the power savings in the settings app.

As you have old Hardware the kernel can’t handle all this new power-save settings alias you cant update the bios to a compatible one with new kernels.

This topic might give you some help how to do it in the terminal:

Logs from the installer are saved to /var/log/anaconda on the target system, so it could be useful to look at logs created by a failed Fedora 40 installation attempt. F40 default uses btrfs, so the target drive may not be accessible from an old Live Installer, so if you try this approach you should choose ext4 filesystems.

Clicked at the link when you first posted it - did not understand what you intended for me to do with it.

Looked again now and figured I could install 5.15.

My upgrade from F35->F37 failed (probably due to me running the wrong kernel) and the oldest release the copr repo has packages for is F37. Manually tweaked the yum-file to force using the F37-repo even though I run F35 and now I’ve successfully booted the longterm kernel.

Will see if I can bump the Fedora version number now.

1 Like