Installing Fedora 31 & 32 on MacBook Pro Retina

Hello all,

I have tried both Fedora (Gnome) 31 and 32 on both a MacBook Pro Late 2012 and a Early 2013, and the issue is the same:

The liveCDs (31&32) boot up and working just fine on both machines, but Anaconda dies before its GUI comes up. I have tried to start anaconda from the Terminal and then it fails with a message about UnicodeDecodeError. It couldn’t be some sort of architecture-issue since the liveCD boots and runs just fine, right?

I have also booted the liveCD with the Troubleshoot option which has basic graphics, same issue with that Anaconda dies before the GUI is loaded.

What puzzles me is that I used the exact same liveCD (x86) to successfully without a single issue install Fedora 31 on an Asus laptop a couple of weeks ago (loved it!)… Is there a special procedure needed for MacBooks?

Any help would be greatly appreciated - I am aiming on switching from Ubuntu to Fedora because I think the Gnome experience is purer/better on Fedora :smiley:

Try netinstall option … you may have better luck.

  1. :fedora: 33 is out, try to install it…
  2. See What Error give you ( Anaconda ) installer.
  3. If any of this works try, You can use the netinstall image of the Server Edition, which does not present a graphical interface, and You can select different editions with netinstall. It is not limited to just Server.


1 Like

I managed to install fedora 32 (and now also 33) on the MacBookPro Retina by making the installer USB with Etcher.

I was using GNOME Disks earlier (which has worked flawlessly with every distro and architecture for years for me) which worked fine with the Asus laptop, but not the MacBookPro :-/ Weird.

But yeah - Etcher FTW :smiley:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.