Install fails to start on UEFI winnovo vokbook

I acquired a winnovo vokbook and want to install fedora on it.
I dowloaded workstation and created a usable bootable live image using fedora media writer (latest 4.1.4).
The bios of the PC boots onto the usb key and the 3 options are then available for choice.
However none of the options work and just return black screens after selection.
It does not seem to be a graphics card issue (intel chipset).
Does anyone have any idea how to troubleshoot the issue further ? Or even better, have a solution :slight_smile: ?

Hi @pja007! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Me personally, I would check if I can boot installation USB in BIOS (i.e. non-UEFI mode), try booting it on another machine (you can just boot into live session without installing Fedora and so without changing the machine in any way) – to understand, if the USB itself behaves differently on different hardware, i.e. is the USB or your device is to blame.

You can try disabling secure boot in BIOS settings – though Fedora’s USB should boot with secure boot enabled… still you can try if it helps. Don’t forget to enable it back again )

Also it can be useful to try installation/live USBs of a couple of different distros (Ubuntu and OpenSuse, for example) – again, to understand if the problem is specific to Fedora’s USB or generic for all or several Linux distributions.

Can you tell which graphics card does your device have: Intel, NVidia, AMD?

Hi nightromantic,
Thanks for the feedback. I am a long time user of Fedora across a number of other PCs and all is well including this distro (F30 workstation) on my usb key which boots just fine on other hardware.
To just give a bit of info, it does boot into the grub type choices, but after selecting any of the options the screen goes black and nothing happens at all, so no booting. I would have thought the process would be driven from the grub code. I had already disabled / reenabled bios settings (legacy, secure mode, …) all without any luck - and it remains in legacy compatibility mode.
The cpu is a celeron 3350 and graphics Intel HD Graphics is all I have as info.

Out of curiosity. The USB key contains a Fedora respin or the image downloaded from

@pja007, just to confirm: you’ve tried selecting “Troubleshooting” from the USB boot menu? When you select troubleshooting – do you see black screen right again, or do you see submenu (with “Start in basic graphics mode” and “Test memory” items)?

There are also a kernel parameter you can add to Fedora LiveUSB boot entry, that helped people in similar situation on some hardware, it has something to do with graphics. I don’t remember it from the top of my head and I can’t look it up right now… I’ll try to do it later. It’s something like “nomodeset” or something similar.

Please try to find it yourself. It can also be applicable to Ubuntu LiveUSB and maybe other distros, simpthoms were as you describe them: black screen when trying to boot LiveUSB.

And once again, I’m very interested about “Troubleshooting” submenu, do you see it, do you see items under it?

It’s “nomodeset” option, it looks I remembered correctly. And it’s applied by default in the “Start Fedora in basic graphics mode” boot options (under troubleshooting).

You can also add it manually (to any boot option). you have to press “e” to edit selected boot option, then can add anything to the line “linuxefi … some options here”.

In the legacy (BIOS, non-UEFI) mode the line should be “linux … some options”

This option helped me a couple of time when I couldn’t launch live session to install Fedora or maybe Ubuntu.


@alciregi, the Workstation F30 on the USB key is the standard vanilla version off the fedora download site (torrent version). So not a spin.

@nightromantic, I tried selecting Troubleshooting from the menu and had the same problem of the black screen with nothing happening at all. Opening the option editor prior to boot identifies this option starts in basic graphics mode with options “nomodeset” and “quiet” set. I have since tried once more with option “quiet” removed, but still without any luck.

FYI the Bios is American Megatrends’ version 2.20.1270 of 02/08/2019

ls in grub gives these partition settings (multiple GPT GUID partitions). Physically there is an internal solid state hdd (32Gb) + an SSD (128Gb) + my USB key and there is a slot for a SD card, but it is currently unused.

(hd0) (hd0,msdos2) (hd1) (hd1,gpt1) (hd2) (hd2,gpt4) (hd2,gpt3) (hd2,gpt2) (hd2,gpt1) (hd3) (hd4)

Somehow it feels like grub is not passing control to the right device for initialisation.


Patric, do you see “Memory test” option under Troubleshoting menu?

I still think it would be useful to test other distros Live USB’s.

Also, you can try F29 or maybe even F28 Live USB, and if it works – upgrade Fedora in-place to 30 after installation.

I think I’m out of ideas at this point )

Hi @nightromantic,
Thanks for the quick reply.
No I have no option for memory test other than grub command prompts (lsefimmap works fine and does not show anything looking abnormal)
I have processed the linuxefi + initrdefi commands without issue and then when running boot, nothing.
So I’m still at square one.

If you see no memory test option, and if you see linuxefi command, then you’re still booting Live USB in UEFI mode.

Chance for it to work in legacy (BIOS, non-UEFI) mode is pretty slim, but I’d still test it for sure.

Trying “Memory test” itself can provide some information too, as it doesn’t load linux kernel, it loads Memtest program instead. If it loads – then maybe your problem is with the linux kernel.

If it doesn’t load – then the problem is likely to be with something else… grub itself for example.

Hi @nightromantic,

You are right, the bios is good and indicates UEFI version 2.5
However I should be able to boot into Fedora with UEFI without any issues.
The commands I loaded manually seemed to work (i.e. gave me back control) what I did not expect though was to get control back after running “initrdefi /images/pxeboot/initrd.img” as I thought this initialised initrd (systemV) and effectively started the system up.

You should be able – yes, of course, but in practice something fails, and we don’t know what.

Booting without UEFI is a simple thing to test, not very likely to help, but… again, very easy to test) Why trying to start memory test can provide a useful info – I’ve written above.

It looks like you have to enter command boot after initrdefi when you booting from grub manually/ interactively.

I.e. linuxefi and initrdefi just provide information to grub, basically, where are these files located.

And boot command actually starts booting the system.

Also keep in mind that manually entering these commands is no different from adding parameters to existing boot menu entry and then pressing [Ctrl-X] to boot changed entry. I.e. you’re likely to have the same black screen after you enter boot and press [Enter].

hi @nightromantic,
This set of commands is what I had already tested (linuxefi + initrdefi + boot) as posted July 13th.
I get control back from linuxefi + initrdefi but when I run boot, then I get a black screen and nothing at all.
The option I tried was with nomodeset and without option quiet to ensure low spec graphics in case that was an issue and to get the system to issue messages to screen.
I tried running memtest using (hd0)/isolinux/memtest from the grub prompt (command mode) and it failed to launch. Am I missing something here?
Thanks, Patrick.

Hi @nightromantic
Ran the process again after setting grup parameters gfxmode to text and debug to all.
So once again linuxefi ran ok and so did initrdefi, both commands ending with closing (hd0).
Here is the output from boot.

script/lexer.c.321: token 288 text [boot]
script/lexer.c.321: token 259 text [
script/lexer.c.321: token 0 text
loader/efi/linux.c.82: kernel_addr: 0x1000000 handover_offset: 0x190 params: 0x6ffea000
loader/efi/linux.c.85: handover_func() = 0x1000390

and the cursor hangs after the last line with nothing more.
Regards, Patrick.

Patrick, memtest can’t be launched from UEFI, you need to boot from the Installation USB in the legacy/BIOS mode. And when you do, you’ll have an option to launch memtest from Troubleshooting submenu, you won’t have to launch it manually.

Also please check this post:

It looks like a completely different issue (though with black screen too, just as you have), and people reporting it had it on already installed system with newer kernel. So the chance of it helping in your case is pretty slim, it’s a wild shot in the dark, so to say – but again, it’s easy to try.

Basically try to boot with two options added: nomodeset dis_ucode_ldr.

Sadly this all means absolutely nothing to me ((

As I said earlier, I have no more ideas to offer. But consider trying this, it can work (not guarateed to though).

Hi @nightromantic
Good idea about the F28/F29 versions. I will try.
The dis_ucode_ldr option did not give anything though.
Still black screen and nothing more.
Regards, Patrick.

Hi to all,
Since Fedora 32 came out I have retried and hey-presto it now works fine.
Thanks for the help.

1 Like