Input timing not supported by the monitor display

I replaced monitors after my old one died. The dead monitor was running at 1920x1080, but cannot remember if it was 60Hz or else, it was a 2006 Dell ultra-sharp monitor. I replaced it with another Dell Ultrasharp with a larger resolution,m though my old graphics card cannot deliver the high resolutions. My machine is dual boot to Windows, and windows had no issues booting and am running at the same old res of 1920x1080. I did not have to do anything settings wise before I booted Windows and the monitor worked fine.

Upon trying to boot Fedora (32, I need to upgrade…) I could see the booting texts line by line, and the start of the windowing environment (The Fedora logo, and the little animated cirde going round and round) then all of a sudden I got the error message below from the monitor itself …

Not sure how to fix this, I thought that there woudl be some handshaking between Fedora and the monitor to find a workable resolution/frequency like with Windows ?

Any help appreciated, as I cannot get Fedora to work…

…I should have also mentioned that when I instaled F32 on this machine, with the old monitor, I did not have to give any kernel boot settings to grub to boot with my old monitor, it just worked, like it does for Windows now with the new monitor…

I just realized that I also can’t change the resolution in wayland session. There are four options and I only can use one of those (the higher available).

Btw, you could try by adding the custom resolution on the kernel parameter with video=2560x1440@60 or any resolution and refresh rate.

On the boot list, press e, use arrow keys, add above parameter after rhgb quiet. Then press ctrl+x to continue booting.

If it works, change immediately the resolution setting inside the session since above parameter are temporary and will gone after reboot.

Thank you fro the suggestion Syaifur; unfortunately did not work. I put video=1920x1080@60, and monitor returned the same error. I’ve also tried other resolutions/settings after trying the “vga=ask” kernel parameter, which showed only relatively low resolutions (see pic below). I tried 3 of them (all 32-bit), 1280x1024x32, 1024x768x32, and 1280x800x32, all with the same error.

Question… when I do vga=ask, the resolutions presented, are they “stored” in my fedora installation ? i.e. are they part of the Wayland settings that went with my previous monitor, or are they resolved in the moment by Fedora and my grap[hics card, and monitor that I have currently hooked up ? Given the low resolutions that it presents, it makes me think these are old stroed info from my previous working monitor.

One more thing to mention is that my old monitor was DVI, while this one uses HDMI – not sure if this makes a difference, but thought I mention it. My graphics card has outputs for both.

…frustrating, I cannot get it to work… yet Windows has had no issues with the new monitor…

I welcome any other ideas :slight_smile:

…here’s the pics

Not sure about HDMI and DVI.

look like you familiar with tty. Maybe you could login to it. Then switch the display manager to native xorg like lightdm or other (gdm use wayland). Then use xrandr to change the resolution (as long as I know, xrandr only work with xorg). Also remove rhgb quiet from boot parameter to narrow down everything.

Make sure after switching from gdm to run systemctl mask gdm.service to prevent it to run.

About input timing, here an example on my system:

Click to expand
[testcase@fedora ~]$ edid-decode /sys/class/drm/card0-eDP-1/edid
edid-decode (hex):

00 ff ff ff ff ff ff 00 09 e5 bd 06 00 00 00 00
01 1a 01 04 95 1f 11 78 02 24 10 97 59 54 8e 27
1e 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
01 01 01 01 01 01 3e 1c 56 a0 50 00 16 30 30 20
36 00 35 ad 10 00 00 1a 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 fe 00 42
4f 45 20 43 51 0a 20 20 20 20 20 20 00 00 00 fe
00 4e 54 31 34 30 57 48 4d 2d 4e 34 31 0a 00 22


Block 0, Base EDID:
  EDID Structure Version & Revision: 1.4
  Vendor & Product Identification:
    Manufacturer: BOE
    Model: 1725
    Made in: week 1 of 2016
  Basic Display Parameters & Features:
    Digital display
    Bits per primary color channel: 6
    DisplayPort interface
    Maximum image size: 31 cm x 17 cm
    Gamma: 2.20
    Supported color formats: RGB 4:4:4
    First detailed timing includes the native pixel format and preferred refresh rate
  Color Characteristics:
    Red  : 0.5898, 0.3496
    Green: 0.3291, 0.5546
    Blue : 0.1523, 0.1181
    White: 0.3125, 0.3281
  Established Timings I & II: none
  Standard Timings: none
  Detailed Timing Descriptors:
    DTD 1:  1366x768    59.973124 Hz 683:384   47.379 kHz     72.300000 MHz (309 mm x 173 mm)
                 Hfront   48 Hsync  32 Hback   80 Hpol P
                 Vfront    3 Vsync   6 Vback   13 Vpol N
    Empty Descriptor
    Alphanumeric Data String: 'BOE CQ'
    Alphanumeric Data String: 'NT140WHM-N41'
Checksum: 0x22

But I don’t know how to modify edid file.

Btw, don’t forget to take a deep breath. :smiley:


I forgot that xrandr doesn’t work in tty. Maybe you could use startx from there.

Just in case, to go to tty, usually I edit boot list same with above and replace rhgb quiet with 3 then press ctrl+x.

For me it seams that your Fedora still uses the settings from the older monitor.
HDMI and DVI are different interfaces might also have/support different settings.

Please post the exact model of your Dell monitor and download/verifier the resolutions the monitor supports.

Thanks (!) again for the note back Syaifur… I just tried something else, and while it did not fix things, I think it is interesting (more pics below). I edited GRUB command with with video=1024x768@60 and for a moment I thought I was going to succed, as the resolution of both the “Fedora” splash page, and the boot lines showing processes starting etc, were larger than before (compare with my earlier pics above), so it seems GRUB is indeed changing resolutions, but things quit working just about when the windowing environment is called on to start. My guess this issue is with Wayland, which is perhaps trying to use timing/resolution from my last successful use (which was with my old monitor).

This seems like a bad thing, as Wayland shoudl be polling the currently being used monitor, etc. in order to start the windowing environment.

THank you for suggesting I boot into a terminal and not a windowing env. However it was over 20 years ago last time I tried this (yep, I am an old guy…) ao will have to look into how to do it.

Seems to that there should be a way to reset Wayland setting to “factory settings” so that it checks to see what monitor I have and makes it work… just like it would in a new Fedora installation…

…I may be a few days, while I figure this out… Happy new year !


Thanks for the note “ilikelinux” – I think you are correct, Fedora is trying to use my old settings on my new monitor, and its not working. My new monitor is a Dell U2722D and supports a pretty high resolution as presented in the error above.

However, my NVIDIA card does not support the higher resolutions (need a new card), but I am running 1920x1080@60 in windows with no issues (which is what I ran in my old monitor as well.

I’ll be happy if I can use successfully boot into Fedora at 1920x1080@60. HOwever I tried this resolution in the GRUB command, and I got the same error from the monitor, so it seems that whatever got stored in Wayland is something else. I did have a “loaner” monitor while I received my new monitor. Still, like I mentioned above, Wayland should try to make things work with what is on the system currently , and not with “old” settings… ?

UPDATE – my machine is dual boot, Fedora and Windows, and so monitor is used by both.

…seems to me the resolution to this problem is to be able to edit the Wayland configuration… or use Xorg instead as suggested…

Syaifur… thank you for the “update” to your last note, I was googling and found the same – add “3” at the end of the GRUB entry.

So, now that I got that, how do I switch the display manager to Xorg ? By the way, my version of F32 is the MATE version. and just so you know, I am not an “expert” linux user… :slight_smile:

You can boot to terminal mode by doing the following.
Edit the kernel boot command line and remove the ‘rhgb quiet’ and replace it with the number ‘3’. That will boot you into the command line without needing to start graphics.
Then log in and run xrandr to display the current available and used graphics mode.

Once you know the available graphics mode then it can be set (using xrandr) for the system to use. Now use startx and see if the graphics mode will start properly.

What may be happening is that the system is not properly receiving the data from the monitor as to supported modes so it does not know how to configure it.

You might also consider actually doing the upgrade from 32 to 34 while booted in command line (run level 3) mode since it is likely that an updated os can assist with some of those video issues.

What nvidia card do you have? and what is the driver level if you are using the nvidia drivers? It may also be caused by an older GPU and older drivers that do not recognize the monitor specs.

1 Like

Many Thanks for the note JV. My graphics card is also an older one GTX 460, and I did choose the actual NVIDIA drivers in my F32 install, but without being able to boot into it, I have no clue what version they are. I woudl think that I should be able to make things work, since when I boot Windows (same machine) it all works fine at 1920x1080 resolution.

I will try as you suggest and see where I get. Being that I am in Windows now, I’ll be offline while I try this.

Cheers to all

@njaimo As @computersavvy said, you could use startx and since you are using Mate, look like it’s the other ways arround.

@computersavvy look like it’s same problem with the guy with VM. I put my hands off about this. Please assist here. :sweat_smile:

…I’m back, unfortunately with bad news…

runnig commands as su

xrandr did not work, as Syaifur had mentioned. Error was “Can’t open display”

startx also failed with errors in XKEYBOARD keymap compiler (xkbcomp) more details in pics below, unfortunately my monitor is wide and the error spread all width.

…hmmm… not sure why the images did not load, seemed to be good to go

is there a limit on posted pictures ?

…from the pictures here is the XOrg error…

X.Org server 1.20.11
X protocol version 11, revision 0
build OS 5.11.10-200.fc33.x86_64
current OS 5.11.22-100.fc32.x86_64 May 19 2021
Build date: April 2021
build ID xorg-x11-server 1.20.11-1.fc32
log file /var/log/Xorg.0.log Jan 6 2022

modeset(0): initializing kms color map for depth 24, 8 bpc
The XKEYBOARD keymap compiler (xkbcomp) reports:

internal error: could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to X server
dbus[1986]: Unable to set up transient service directory: XDG_RUNTIME_DIR “/run/user/1000” is owned by uid 1000, not our uid 0
Failed to connect to bus: operation not permitted
xinit: connection to Xserver lost
waiting for Xserver to shut down. Server teminated succesfully. Closing log file

While waiting for suggestions from others, may be you could try with sudo startx.

~~Since you’re using Mate-Compiz, the desktop manager should be SDDM. Here some configuration references maybe you could use as reference