Ingition mounting not working, please help

24 hours I’ve been banging my head against this and reading every little scrap of info I can find online.

Relevant config section -

storage:
  disks:
  - device: /dev/sdb
    wipe_table: true
    partitions:
    - label: "varlibdocker"
      number: 0
  filesystems:
    - path: /var/lib/docker
      device: /dev/disk/by-partlabel/varlibdocker
      wipe_filesystem: true
      format: xfs
      label: VARLIBDOCKER

Messages from first boot, it creates the FS and all that, mounts it, but then unmounts it -

[core@FCOS-1 ~]$ dmesg | grep /var/lib/docker
[   11.438438] ignition[494]: INFO     : mount: op(2): [started]  mounting "/dev/disk/by-partlabel/varlibdocker" at "/sysroot/var/lib/docker" with type "xfs" and options ""
[   11.439852] ignition[494]: DEBUG    : mount: op(2): executing: "mount" "-o" "" "-t" "xfs" "/dev/disk/by-partlabel/varlibdocker" "/sysroot/var/lib/docker"
[   11.452315] xfs filesystem being mounted at /sysroot/var/lib/docker supports timestamps until 2038 (0x7fffffff)
[   11.456586] ignition[494]: INFO     : mount: op(2): [finished] mounting "/dev/disk/by-partlabel/varlibdocker" at "/sysroot/var/lib/docker" with type "xfs" and options ""
[   14.169158] ignition[640]: INFO     : umount: op(1): [started]  umounting "/sysroot/var/lib/docker"
[   14.169878] ignition[640]: INFO     : umount: op(1): [finished] umounting "/sysroot/var/lib/docker"
[core@FCOS-1 ~]$

and by the time I log in, it’s not mounted -

[core@FCOS-1 ~]$ df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        1.5G     0  1.5G   0% /dev
tmpfs           1.5G     0  1.5G   0% /dev/shm
tmpfs           1.5G  648K  1.5G   1% /run
tmpfs           1.5G     0  1.5G   0% /sys/fs/cgroup
/dev/sda4       7.5G  1.8G  5.8G  24% /sysroot
tmpfs           1.5G     0  1.5G   0% /tmp
/dev/sda1       364M   88M  254M  26% /boot
/dev/sda2       127M  8.5M  119M   7% /boot/efi
tmpfs           299M     0  299M   0% /run/user/1000
[core@FCOS-1 ~]$

I’ve tried changing the config formatting, entries, using different paths, creating an fstab file, and many things that I’ve already forgotten that I tried because I’ve tried so many things.

I’m sure it’s one stupid little thing. If someone could point it out that would be GREATLY appreciated.

You probably need to set with_mount_unit: true. See the example from the FCCT docs.

1 Like

That was it, thank you so much! I didn’t see that in any of the other examples I checked … I guess they were all pre-Fedora CoreOS or something :-/ … oh well, working now, thanks!! :slight_smile:

1 Like