Importing keys for 35

I have such a trouble with keys. I manually copy paste keys but no luck. Can someone tell me syntax for importing keys for 35 that I can jump from 32 to 35. I totally forgot how to do it. Thanks.

error: PKI file /var/cache/rpm-ostree/repomd/fedora-35-x86_64/RPM-GPG-KEY-fedora-$releasever-$basearch is not a public key

I lost all my spark as I also have syslog so full and need to get rid of flatback unused files as the cleanup commands did not wanted respond. Finaly I gat clean enough to be able to load upgrade. And then batle with keys. Sometimes it is too much.

Hello @juhafinlandvoaa ,
Long time, how’s things?
Isn’t it just gpg --import <keyfile> ?

Why it gives such a error? What cahce, though keys are /etc/pki/rpm-gpg/?

error: PKI file /var/cache/rpm-ostree/repomd/fedora-35-x86_64/RPM-GPG-KEY-fedora-$releasever-$basearch is not a public key

You must have the public key file from the repo, which is usually set with ostree I think.
Something like sudo ostree gpg-sign <repo> <key-id> I think.

Noup, I noticed that key is generated to next version so if I go from 32 to 33 it should work. But that version was not functional, with WWAN. I have problems with basics. What is the permissions to key file. Where they are and why import so challenging to me.

pm-gpg]$ curl https://getfedora.org/static/fedora.gpg | gpg --import
and then chmod 400 RPM-GPG-KEY-fedora-35-x86_64
error: PKI file /var/cache/rpm-ostree/repomd/fedora-35-x86_64/RPM-GPG-KEY-fedora-$releasever-$basearch is not a public key

I read that there is bugs with the same error. Could be this one also?

I was testin so that rebase 33 work but not to 34 nor 35. It means that you can normaly upgrade on steo upstream. WWAN did not work in 33 and need to stick 32 ann use cleanup -r to have clean ostree. What I did noticed. that status show that public pki key is not check in current deployment 32 but in the case where 33 was loaded it was. As when I try to jump 32 to 35 it says the same. What is public pki and where I can load it or look? I assume that primary key is the public key. So if I do sudo su
wget https://src.fedoraproject.org/rpms/fedora-repos/raw/rawhide/f/RPM-GPG-KEY-fedora-35-primary
I do not get any diference. I read that publick key was changed from 32 to 33 and no warning. What should do to have this key from where and to write where and what permission to write to it. Very confusing.

rpm-ostree rebase fedora:fedora/rawhide/x86_64/silverblue didn’t work to go from 32 to rawhide? So also if WWAN is not working in F33 for you maybe just download the F35 iso and use that to upgrade from.

I would recommend rebasing from 32 to 33, then 34 and finally 35 to let the system handle configuration & state updates for your applications.

Sure this was first what come to mind. WWAN do not work in 33 and it was the reason to stick 32. For me it was no go situation as it is only network bus and PC will be useless as it is in cloud and learning environments etc. So there is only that install it again from image but it si trouble to pack files. It eats idea of silverblue. I still hope that there is way to jump 35. I also try rawhide and no luck.

Maybe you can try getting the keys from /etc/pki/rpm-gpg/ on a modern Fedora and copying them to your older installation.

What do you mean?

If you know someone who has an updated fedora system you can copy the keys (files) from where @Siosm says above to your system into the same location. That would solve your GPG signing issues for the latest Fedora. I just looked in mine, there are ones going back to F7!

I have one more suggesttion. Will open toolbox and upgrade there and copy from there keys. But was it dnf system-upgrade download --refresh --releasever=35 or how it was done. I forgot those already.

Yes, that will work, I just tried to diff both files (the one I have on my Host system, and the one in the toolbox “system”) and they are identical (/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-35-primary file). So I copied the file I found in toolbox into my home dir first, then tried diff RPM-GPG-KEY-35-fedora /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-35-primary and it showed no results, meaning no difference.

Oekiokei. But what was syntax for RPM update?

sudo dnf update

Yes that one I do remember. But it gives update for 32 what i currently have. How I can update by rpm to 35. In ostree you list versions and rebase but can not remember how it goes in rpm?

Is this inside of Toolbox? You could just use media writer to make an USB iso couldn’t you? Or net install in a VM (F35 that is), then copy the keys. If you can boot F32, you should be able to just do the rebase to F34 first then F35. A jump of more than two releases seems to give issues to most trying it, as in it usually fails.

You don’t need to upgrade toolbox across major releases. You can just create a new one on the new release and copy the keys from there.