I915 kernel option tainting kernel (64) - prevent bug report

Hello everyone,

I have switched from Ubuntu to Fedora and just finished a full system re-install with 95% of the set-up I had with Ubuntu so far. One bug I used to have, which seems to remain up to now with the drivers is that the wifi stops working from time to time on Ubuntu (AFAIK, normal with the wifi card of XPS 13, ath10k, nothing to do but reboot).

When this issue first occurred with Fedora, system says cannot send bug report because I run tainted kernel. I investigated a bit more and it seems that it comes from kernel option deemed unsafe, enable_psr=0. I have to set this because of a flickering issue which has been well documented and still seems unresolved with out of the box kernel.

This option was probably also tainting my Ubuntu box but never noticed it because it never threw an error after a system issue. Is there some sort of bug I should fill to see if Fedora can enable reporting with tainted kernel and/or that this option would not taint the kernel? I have found the following links that support the fact that i915 options taint the kernel, both fairly old incl. one of Linus:


Output of cat /proc/sys/kernel/tainted is 64 & dmesg | grep -i “taint” is [ 2.585190] Setting dangerous option enable_psr - tainting kernel. My /etc/default/grub files contains GRUB_CMDLINE_LINUX=“… i915.enable_psr=0”

I checked journalctl | grep ‘taint’ and this message started to appear after a fresh fedora install before I started to install my other packages, etc. (I stuck to official repos anyway) and I presume as soon as I modified grub default config file to include the psr kernel option.

Any thoughts appreciated. I would probably think that deactivating the self refresh rate is not a dangerous option that should taint the kernel / prevent from reporting bugs?

PS: In case anyone has an idea about the ath10k driver issues :slight_smile:

Edit: Initially, I was not sure that it was possible to get a “clean” kernel after it’s tainted, but it seems so. I removed the option at boot time and do not have now a tainted kernel. I’ll see if the flickering comes back after the last kernel update but at least the issue is clearly linked to dangerous kernel options.