I have autologin enabled but still have to type my password

… is it not possible to circumvent this password dialog?

Also if i mount external drive in filemanager the password dialog appears, how to avoid that?

I suspect that you have been logged in to the desktop environment, is that the case?

But you have not unlocked the secrets in the keyring needed to, for example, mount a network drive. For that you will need a password, not sure if you can by passwordless on the keyring.

You can make your password keyring password-less using Seahorse. Not recommended, it’s a security hole.

This topic passwords on linux is not arranged well for a person like me: single PC and i am user plus sysadmin, so no need to be anxieous like living in a great network of a huge firm.

I remembered seahorse from former adventures with gnome:
Installed seahorse, started it, removed all settings i could reach, saved, rebooted, deleted seahorse again and now its nearly ok: only on mounting foreign OS partition and google for the first time i see this annoying password manager.

I run XFCE because i’m used to it.

Anyway thanks for that tipp !