I could use some help setting up BTRFS timeshift backups

Greetings fellow humans, human fellas.

I’ve been trying to rename my /root and /home subvolumes to work with Timeshift.
Following this : Willi Mutschler guide on my encrypted install worked very well.
However, I am now not using an encrypted system, and I can’t seem to figure out the exact command I must use.
I am stuck at step 2

Mount the btrfs top-level root filesystem

Let’s mount our the top-level btrfs volume (which has always id 5):

mkdir /btrfs_pool
mount -o subvolid=5 /dev/mapper/luks-6e7e8f26-4f38-468e-aa2c-9ddaaad4aedf /btrfs_pool
ls /btrfs_pool
# home root

I am unsure what to replace /dev/mapper/luks-6e7e8f26-4f38-468e-aa2c-9ddaaad4aedf /btrfs_pool with.

[paul@localhost ~]$ mkdir /btrfs_pool
mkdir: cannot create directory ‘/btrfs_pool’: File exists
[paul@localhost ~]$ sudo -i lsblk
[sudo] password for paul: 
sda      8:0    0 119.2G  0 disk 
├─sda1   8:1    0   600M  0 part /boot/efi
├─sda2   8:2    0     1G  0 part /boot
└─sda3   8:3    0 117.7G  0 part /home
zram0  252:0    0   3.8G  0 disk [SWAP]
[paul@localhost ~]$ ls /dev/mapper
[paul@localhost ~]$ sudo blkid
/dev/sda1: UUID="3A13-3215" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="92dcd394-ce3e-4b0c-8a3f-853d07a6d42d"
/dev/sda2: UUID="900fde7b-c639-4c2e-af1f-d4d5da91546d" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="b2572080-2f0a-47d1-af5a-68f547714f61"
/dev/sda3: LABEL="fedora_localhost-live" UUID="c7316faf-8402-4668-9ef1-99944da634cb" UUID_SUB="26992d7f-bf58-4f23-a43d-a4dc52c82d9f" BLOCK_SIZE="4096" TYPE="btrfs" PARTUUID="64ca49b0-de67-4d56-b105-66f84044ef5c"
/dev/zram0: UUID="527355fd-4696-4f28-939a-14e2988025ef" TYPE="swap"

The above is my default system install. Which partiton must I use to follow the above guide?
Thank you all in advance.
I hope you have a splendid day.

1 Like

NVM. i solved it. I forgot to add additional arguments at the end.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.