I cant connect to any wifi

hello guys
i cant connect to any wifi now
i cant really remember if it worked after i upgraded to 6.3.7 kernel or not but i booted to 6.3.6 kernel and its the same.
this is the error i recieve on kenel in journalctl

Jun 16 04:16:09 imieeet kernel: wlp5s0: authenticate with 14:eb:b6:61:35:36
Jun 16 04:16:09 imieeet kernel: wlp5s0: No basic rates, using min rate instead
Jun 16 04:16:09 imieeet kernel: wlp5s0: 80 MHz not supported, disabling VHT
Jun 16 04:16:10 imieeet kernel: wlp5s0: send auth to 14:eb:b6:61:35:36 (try 1/3)
Jun 16 04:16:10 imieeet kernel: wlp5s0: send auth to 14:eb:b6:61:35:36 (try 2/3)
Jun 16 04:16:11 imieeet kernel: wlp5s0: send auth to 14:eb:b6:61:35:36 (try 3/3)
Jun 16 04:16:12 imieeet kernel: wlp5s0: authentication with 14:eb:b6:61:35:36 timed out

i googled it and found something related to 11n wifi standard, now i enabled my phone hotspot in wifi 6 mode(802.11 ax) and its still the same
also my wifi card is ok as it works in windows 11 dual booted
update: i just found out that every boot i got an kernel error containing this:

WARNING: CPU: 13 PID: 486 at drivers/gpu/drm/amd/amdgpu/../display/dc/dce110/dce110_hw_sequencer.c:783 dce110_edp_wait_for_hpd_ready+0x163/0x180 [amdgpu]

it mentions something gpu related
it never happend before, also with the new kernel 6.3.7 i also updated mesa, so maybe its something to do with mesa?

It is hard to help you without knowing make/model/chipset of your WiFi…

its a mediatek mt7922
also its a ga402rk laptop if that helps

Quick Google search gave me this instruction - USB-WiFi/home/How_to_Install_Firmware_for_Mediatek_based_USB_WiFi_adapters.md at main · morrownr/USB-WiFi · GitHub

And some more info on same WiFi chipset - Reddit - Dive into anything. If your laptop and WiFi are user-serviceable and you want permanent solution to this problem, I’d suggest you to “get your hands dirty” and replace WiFi module with Intel-based one.

What you show is a warning, not an error.

Replace the wifi module with one that gets good reviews from linux users. Intel wifi has been good, but Intel has a table that shows the status of their firmware for each model – some recent models may not yet have robust firmware. Other options are wifi bridges that provide a network jack without the need to run wires, and USB wifi adapters (some include fancy antennas that get reliable wifi where internal laptop wifi fails.

ty, its fixed by itself now, if it happens again i will try that

@gnwiii @arturasb for changing wifi card, im trying to wait for warranty to end so i can change my micron ssd into a decent samsung one too.
and it was working on linux since day one i bought it, i doubt a product support gets worse in a update. or does it?

A new kernel often requires changes to drivers. Drivers from linux.org generally work, but linux developers are human, so mistakes do occur and won’t be fixed until a user generates a bug report. Some vendors neglect their drivers, while other vendors (Intel, and now AMD) contribute to kernel and driver development.

If you rely on wifi, it is a good idea to have a backup plan. The simplest way to ensure wifi is usable is to have one of the many cheap USB dongles (use Linux Hardware Database (LHDB) to find ones with chipsets that work with “in kernel” drivers. Avoid USB wifi vendors that don’t specify the wifi chipset, as some vendors sell mulitiple chipsets under the same name.