I can not upgrade after closing the update halfway for checksum mismatch

Hello everyone.

I tried yesterday to upgrade to fedora 34 beta using dnf-plugin-system-upgrade.It went fine yesterday but due to the time required I closed the upgrade halfway and went to sleep.Today when I tried to continue to update I got the error like

Errors during downloading metadata for repository ‘updates’:

  • Downloading successful, but checksum doesn’t match. Calculated: 19681c5615cb30a94e569f2a3e743e5b74a3ac4c5966026fff54050e55af377addb3809710363328cbe8a4bd7887ce892f0051463eafa597e5a992b2555751f5(sha512) 19681c5615cb30a94e569f2a3e743e5b74a3ac4c5966026fff54050e55af377addb3809710363328cbe8a4bd7887ce892f0051463eafa597e5a992b2555751f5(sha512) Expected: 0ad51d1c6ca1c78b9e6ea7c3643e6f45893a7d053d1e2e890343097a83cca8e22d69994c57516f86e62a9466101a66ccc964d453fdf6178d2a1f4bf13d02801d(sha512) 45e9fd5cc91cd311df7639bc1046657c513626eb09e6e159de2bcdd1a2c81510a87bf47d1661072a052dac315dd06a29b6960edfbfc3dae0674347175fd7d50b(sha512)
    Error: Failed to download metadata for repo ‘updates’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

How to solve this error?Thank you in advance.

1 Like

We are very close to get F34 rolled out. There is a lot to sinc between the mirrors. Be patient and try again.
Maybe this helps:
dnf --refresh #set metadata as expired before running the command


I will wait for that.I just wanted to know what caused that error.
Thank you!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.