I am getting black screen after i run the command fsck.ext4 -vf /dev/mapper/federa-root in emergency mode

I got this after I was trying to solve the boot problem.After the command there was a option to clear garbage and I type yes.After rebooting , I am getting this black screen with only fedora logo is showing on the bottom of the screen. Please help me to figure this out.

   Hi @pscoder.  During boot of your machine, hold the Esc key to access GRUB menu.

and remove the word quiet, then press Ctrl X.

PS:  Is the file system was unmounted when you’d ran this command (i’m sorry, just want to know about these things)?

Thanks for the reply but I am still getting blank screen. Before this I was getting emergency mode with the error message of Failed File system check on /dev/mapper/fedora-root. Resolving that issue I came up with this problem. I am using bootable ssd on my laptop

   Ok, lets hope that someone with a knowledges about FSes will kick in there.  Do you’ve any Live media to boot in?  IDK what to do, but that can come in handy.

I have live media but don’t know how to resolve the problem using it.I don’t want to fomat the drive

   You can run fsck from it, install programs (to RAM) to extend the Live’s functionality, browse the filesystems (working ones), and probably many more.  No need to format anything (the “Try Fedora WIthout Install” option).