HW detection: internal wifi

I’m not able to use my internal wifi (only an external one attached to a usb port, so I have a workaround).
If you need further details, please send me the cmd to run.
Thanks in advance

I ran a probe and the results are here.
this seems to be the only relevant part:


Hello @giuliohome
You have a broadcom card.
Its drivers aren’t open source, so they can’t be included in Fedora repositories.

You have to install RPMFusion repositories. Probably they are there. I can’t verify if your model is supported right now.
Try to search in this forum. If I remember, the issue was already covered various times.

1 Like

Yes, I’m reading this post indeed, but it’s a bit old, not sure how to translate the commands into my current Fedora version 31… Thanks

You are reading the old forum. There, you risk to find outdated info.
Instead, use the search function of this forum.

For instance you can find this answer:



BTW, yum was deprecated, and the command to install packages in Fedora is now dnf.

1 Like

Followed the instructions unitll
sudo dnf install akmod-wl
and rebooted but it is still not detected…
Now I’m doing sudo dnf update -y && reboot which I previously skipped…

It worked as expected.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.