Huion 610PRO V2 Graphic Tablet does not work using Fedora 36 Design Suite

I am having a problem getting my Huion 610PRO V2 graphics tablet to work with Fedora Design Suite. Recently upgraded from 35 to 36 and tested the graphic tablet with a short start up where it does work for a few seconds and then nothing. Tried a dnf search using the keyword Huion yet that resulted in nothing being returned. Is there some type of special rpm package driver or other stuff that needs to be installed to get this tablet working? Tried Huion support to locate a proprietary driver for Linux Fedora and found a Linux driver for Ubuntu yet nothing for rpms. Oddly on the same computer desktop I have recently upgraded to Debian Bullseye 11, with this operating system the tablet works fine including full pressure sensitivity without installing the proprietary driver. Debian is an operating system that is tailored more to developers instead of graphic arts enthusiasts yet the tablet works fine on that operating system.
Also have Windows 10 on this computer desktop, tablet works on that operating system yet some proprietary software such as Corel does not have pressure sensitivity as some of their software programs do not support Huion drivers.

I specifically use Fedora Design Suite for graphic arts work, being this is a lab custom creation of the Fedora Workstation that is made for people that work a lot with graphic arts and design . Seems this operating system would be the least likely to have problems with graphic tablets since they are an essential part of working with digital painting and drawing. I have a six to eight year older Huion tablet that does work with this Design Suite yet this 610 model (approximately 3 years old) is not functioning at all. 2022-07-18T04:00:00Z

Try Alien, a file converter to use .deb on .rpm

Be careful. Alien will usually convert the package but may not properly handle dependencies. IME it does not usually handle the dependencies.

1 Like

Here’s a repository with drivers for tablets, from time to time kernel drivers are synced with it: GitHub - DIGImend/digimend-kernel-drivers: DIGImend graphics tablet drivers for the Linux kernel
It may contain fixes not yet available in Fedora kernel. Debian has older kernel, so there might have been some regression in the meantime, hence the difference. Try switching to x.Org on login screen - in case this issue is related to Wayland.

Please provide the output of xinput command.

For my Kamvas 13, installed Driver_15.0.0.89.tar.xz_Beta (Ubuntu) ( works perfect

Just this week I installed Unbuntu Studio 22.0.4 and the Huion tablet works fine on that operating system.

I’ve been using Fedora Design Suite since version 25 and have experienced graphic tablet problems of all different varieties. I have several different graphic tablets that were purchased over the past 15 years. Its a good experience saving them instead of throwing them out since you never know what tablet will work on different operating systems. Chances are one will work with full functionality such as pressure sensitivity. I was hoping this Huion tablet would work since it is a comfortable tablet to work with and is comparable to a much more expensive Wacom Intuous Pro.

This issue of drivers is a problem with all the operating systems I have tried and experienced using Windows or Linux. Things change constantly yet with some operating systems quicker than others. Some tablets become deprecated after time and no longer supported. This is where you might run into a second problem, will the software support that type of model graphic tablet.

Thanks for the lead here yet could not find anything for this particular Huion 610Pro V2.

I have this problem with different operating sytems using graphic tablets constantly. Since Fedora Design Suite 25, sometimes they work other times problems. Same thing with Linux Mint, LInux Debian, and Windows different versions since XP.

I have several different graphic tablets for this reason alone that have been accumulated over the past 15 years. I’ll usually find one that works with an operating system. I would conclude that constant change is the problem here, drivers and their tablets become obsolete yet some operating systems are slower to change so older tablets work yet newer ones do not.

I would like to get this Huion tablet working with Fedora Design Suite since I like this operating system and the comfortable feel of working with this tablet model. It is very similar to a more expensive Wacom Intuous Pro tablet yet a lot less in cost, less than $75. I have an older tablet that seems to work with Fedora okay and has worked with past versions of Fedora Design Suite and Workstation.

I had Debian Bullseye 11.3 installed on a desktop and this particular Huion tablet did not work at all. Same problem using a Mint 20.3 operating system.

This tablet does work on Windows 10 and recently installed Ubuntu Studio 22.0.4 with good results for full function use of this tablet (pressure sensitivity). Overall this particular tablet seems to work best using Windows 7.

Thanks for the warning, usually experimenting gets me into trouble and a huge time loss.

Not quite sure the problem here is a driver. For some odd reason when I first start up Fedora the tablet will work on the first program I open; GIMP, MyPaint, or Krita. I notice full pressure sensitivity for a couple of brush strokes and then it dies out, nothing.

?, get a terminal reply message xinput, command not found.

Remove any drivers you tried before or install fresh Fedora Design Suite, if the tablet doesn’t work out of the box, try switching between Wayland and x11/x.Org on login screen. If after that it still doesn’t work, install DIGImend drivers. Multiple people reported them to work with this model years ago: Issues · DIGImend/digimend-kernel-drivers · GitHub
lsusb will show you the USB ID of your tablet, by searching for it, you’ll probably find more references to your model.

Taking high level vision … when you use Fedora, you’re working with Red Hat. Something special used in industry and corporate environment completely secured as a concern today as before. Linux kernel developers focus on security also and Red Hat is involved with many apps and software projects. Microsoft is also involved in software explaining automatic configuration. Debian has a different approach with older kernel versions, Huion has Ubuntu version of a driver for the tablet, use it with Alien as the distribution has liberal approach to closed source software and what you need is a simple digital blob compiled for specific hardware on Linux platform.
Linux kernel developers are kicking out compatibility features, Microsoft moves to W11 using lean version of Windows NT so what happened? Read Fedora Export Compliance/Customs Information on their site, simply compatibility level kicked out in recent kernel versions or a Fedora bug. Answers given are sincere but not all USB devices appear for a good reason as using multiple functions in USB specification not always implemented in basic GNU tools.

Might as well simply wait for future releases. Personal experience from using Fedora Design Suite since version 25 is that eventually the tablet will work. Had a similar problem years ago with an older Wacom Intuous 2 graphic tablet. Again similar problem with an older Huion tablet that now works on this version of Fedora 36.

My personal opinion is outside of this problem Fedora Design Suite 36 is the best experienced since 25. They brought back Amarok here a multimedia player that has the best data sorting engine so far as accuracy in organization is concerned. Also has a nice link to wikipedia when you play a recording artist that presents you with information and history of the recording artist. Almost everything else works excellent in this 36 version. To carry it one step further this is the best version of any Linux operating system that I have experienced.

What’s your take on Fedora vs Ubuntu Studio? I currently am a dilemma and I don’t know what to choose.

It’s a question of choice staying with mainline Linux distributions … try Ubuntu to see if graphic tablet works with driver downloaded on Huion website. Spins like Design or Studio can be customized. Fedora is a fast moving release, Ubuntu LTS stable that I use for Intel, NVidia, ROS, Google software as easy configuration with 20.04 as 22.04 a bit wobbly, Fedora on Microsoft Surface Go with Microsoft Edge navigator connected to Office on line.

I would seriously consider compatibility with your graphic card in a circumstance where you want to use an add on card instead of the one integrated in the motherboard. Generally the integrated graphic card has the best probability of working well with Linux operating systems. Your specific interest and needs may require an upgraded graphic card. I would check both operating systems by using the live versions of the operating systems and see which one provides the best compatibility with your hardware. You might try repositories and test the installation of necessary drives for making the graphic card work, sometimes this option works with a live version of operating system run from a thumb drive or DVD.

I may have written my opinon about Fedora 36 Design Suite a bit prematurely.
Had a disaster this week, not caused by Fedora instead Linux Mint.

I have a multi operating system desktop set up. This week the Linux 21 became available and I had Linux Mint 20.3 set up as one of the multi operating systems. Followed the instructions step by step with exception of making a back up since I did not have enough memory anywhere to do such.
Had a really good set up with Mint, Wine worked excellent, never any problems. The only reason I upgrade is to keep up with security updates not to redesign my operating system functions and features. After upgrading my computer became really slow and the boot loader was destroyed. Simply faced the grub rescue. Tried the Repair Grub Bootloader yet that option as suggested in the instructions for upgrading Linux Mint to 21 did nothing. Tried to re-install the older 20.3 version of the operating system over the partition where 21 was installed and for some reason the live version installed without any boot loader and wound up with everything lost. Tried to remove and rearrange where the boot loader would point to open up a menu and nothing worked. Could not get into the Fedora Grub 2 config file to possibly change the menu there, was locked out attempting to use a live version of Fedora or Mint. In the end I had to remove Mint and Fedora 36 that both worked very well and took many hours to set up for personal use. I did re-install the Fedora 36 operating system over a partition and was able to get this installed yet could not even get the older Mint 20.3 thumb drive with live version to boot up, strangely since this was the exact thumb drive I used to install the os last year and it worked fine. After catching a lot of criticism about running older versions of operating systems due to security issues where support no longer is available I decided to keep up with the changes. Now I experience the same thing they warned about occurring from upgrading, security issues causing problems that may effect your operating system. As a result of taking that advice and upgrading I have lost everything trying that option.
You may be better off taking your chances with something that is obsolete, simply keeping it off the internet, or at least minimum for critical problems. As the old cliche goes “If it ain’t broke, don’t fix it”.

The newly installed Fedora Design Suite has a problem, the Wine application does not work at all, along with a lot of other problems I never had with the first install. Same problem with the Huion graphic tablet. This has left me very depressed, all the hours of work setting up those operating systems and loosing everything, and now getting back only one operating system that is not working as well as the first install. I will never make any comments about any operating systems working good again. I feel very stupid making any comments after this experience.

It’s unfortunate, but I’d say this is a result of your lack of experience and trying to run an unusual set-up. Multiple Linux distributions on one machine in multi-boot set-up is pretty uncommon in my experience and requires good knowledge of each distribution idiosyncrasies to maintain in working order. In-place upgrades or new installs are exactly the scenarios when things are likely to break in multi-boot set-up. Your story doesn’t contain enough clues to say what went wrong. I think you can’t blame either Mint or Fedora for this because such multi-boot scenarios are not supported or tested.

I’m having the exact same problem with just Fedora 36 installed (KDE Spin). My Huion 610PRO V2 works for a few seconds and then doesn’t until it’s unplugged and plugged in again. It worked perfectly on Pop. I don’t think this is an issue with their system or multibooting.